Page MenuHomePhabricator

phab.wmflabs.org does not offer login
Closed, ResolvedPublic

Description

Why is login disabled on the phabricator test server? The login form doesn't show up completely and the login form worked with this browser a while ago. Hopefully this info from my chrome version helps:

Google Chrome 61.0.3163.100 (Official Build) (64-bit) (cohort: Stable)
Revision 57c9d07b416b5a2ea23d28247300e4af36329bdc-refs/branch-heads/3163@{#1250}
OS Windows
JavaScript V8 6.1.534.41
Flash 27.0.0.183 C:\Users\puntg\AppData\Local\Google\Chrome\User Data\PepperFlash\27.0.0.183\pepflashplayer.dll
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.3

I am using this on Windows 10 Home. Thanks

Event Timeline

Sau226 created this task.Nov 4 2017, 11:02 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 4 2017, 11:02 AM
Sau226 updated the task description. (Show Details)
Reedy renamed this task from Login disable on phabricator instance to Login disabled on phabricator instance.Nov 4 2017, 4:58 PM

Thanks for reporting this! Looks like this is about https://phab.wmflabs.org/

Might be a regression from T963#3700724

Aklapper renamed this task from Login disabled on phabricator instance to phab.wmflabs.org does not offer login.Nov 4 2017, 5:31 PM
Paladox added a subscriber: Paladox.Nov 4 2017, 6:24 PM

Yep that is a regression. reverting that changed fixed the login dialog.

Sorry @Paladox but the form went poof too. Maybe disable ldap connections and use an SQL database if possible?

It uses the puppet role, so puppet overrides anything i set.

Sau226 added a comment.EditedDec 13 2017, 9:54 AM

OK. I think this needs fixing since only people with shell access to that server are able to log in while people like me who do not have shell access can't even log in (yet the server is advertised as being a test server).

@mmodell hi, would you be able to fix this please? :)

I’ve identified the change that broke this which I reverted here https://phabricator.wikimedia.org/D869

This seems to be fixed now since i enabled mediawiki oath (oauth wont work for any one that try it but it at least now allows users to click the right login form and login).

Sau226 added a comment.Jan 6 2018, 7:11 PM

Thanks. I'll try it again

Sau226 closed this task as Resolved.Jan 6 2018, 7:17 PM
Sau226 claimed this task.

Seems to work (for now)