Page MenuHomePhabricator

Thank action failed (error code: badtoken). Please try again.
Closed, DeclinedPublic

Description

I get

Thank action failed (error code: badtoken). Please try again.

on https://uk.wikipedia.org/w/index.php?title=Обговорення_користувача:Вакуленко-К._Володимир&action=history&uselang=en / https://uk.wikipedia.org/w/index.php?title=Обговорення_користувача%3AВакуленко-К._Володимир&type=revision&diff=21392395&oldid=21392194&uselang=en
when attempting to thank for the edit.

Response headers from browser console (tokens removed)

HTTP/2.0 200 OK
Date: Tue, 07 Nov 2017 14:43:01 GMT
Content-Type: application/json; charset=utf-8
Content-Length: 239
Server: mw1227.eqiad.wmnet
x-powered-by: HHVM/3.18.6-dev
Vary: Accept-Encoding
Content-Disposition: inline; filename="api-result.json"
x-frame-options: DENY
mediawiki-api-error: badtoken
Content-Encoding: gzip
p3p: CP="This is not a P3P policy! See https://uk.wikipedia.org/wiki/%D0%A1%D0%BF%D0%B5%D1%86%D1%96%D0%B0%D0%BB%D1%8C%D0%BD%D0%B0:CentralAutoLogin/P3P for more info."
Cache-Control: private, must-revalidate, max-age=0
X-Content-Type-Options: nosniff
Set-Cookie: ukwikiSession=REMOVED; path=/; secure; httponly
ukwikiUserID=101507; expires=Wed, 07-Nov-2018 14:43:01 GMT; Max-Age=31536000; path=/; secure; httponly
ukwikiUserName=Base; expires=Wed, 07-Nov-2018 14:43:01 GMT; Max-Age=31536000; path=/; secure; httponly
forceHTTPS=true; expires=Thu, 07-Dec-2017 14:43:01 GMT; Max-Age=2592000; path=/; domain=.wikipedia.org; httponly
centralauth_User=Base; expires=Wed, 07-Nov-2018 14:43:01 GMT; Max-Age=31536000; path=/; domain=.wikipedia.org; secure; httponly
centralauth_Token=REMOVED; expires=Wed, 07-Nov-2018 14:43:01 GMT; Max-Age=31536000; path=/; domain=.wikipedia.org; secure; httponly
centralauth_Session=REMOVED; path=/; domain=.wikipedia.org; secure; httponly
CP=H2; Path=/; secure
backend-timing: D=38791 t=1510065781013990
X-Varnish: 304350121, 586351288, 65318556
Via: 1.1 varnish-v4, 1.1 varnish-v4, 1.1 varnish-v4
Accept-Ranges: bytes
Age: 0
X-Cache: cp1066 pass, cp3043 pass, cp3031 pass
X-Cache-Status: pass
Strict-Transport-Security: max-age=106384710; includeSubDomains; preload
x-analytics: WMF-Last-Access=07-Nov-2017;WMF-Last-Access-Global=07-Nov-2017;https=1
X-Client-IP: xxxx
X-Firefox-Spdy: h2

UA: "Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0"

Event Timeline

Base created this task.Nov 7 2017, 2:49 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 7 2017, 2:49 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptNov 7 2017, 2:54 PM
Legoktm added a subscriber: Legoktm.Nov 7 2017, 5:19 PM

What happened when you tried again?

Base added a comment.Nov 7 2017, 6:36 PM

The same. It actually turned out that I cannot edit too, the expired session thing (at least for edit the error is human understandable). I was reloginning already. Though when logged in Private tab I am able to edit. Also I can edit on Meta just fine.

Base added a comment.Nov 7 2017, 6:41 PM

On relogin I end up on https://uk.wikipedia.org/wiki/Special:CentralLogin/complete?token=REMOVED :
Central user log in
No active login attempt is in progress for your session.

Return to the previous page.

Base added a comment.Nov 7 2017, 6:44 PM

On reload then I appear logged in again, though I still have the same problems. On other wikis (and other devices, the main thing why I loathe ever logging out on Wikimedia sites) I am logged out after that though.

So what exactly are you filing a bug about? The fact you got logged out? Or the thanks error message?

Base added a comment.Nov 7 2017, 10:42 PM

Well I have encountered it with thank message, I guess on thank's part a good task out of this would be to provide more meaningful errors than "badtoken". As a user I am not supposed to even know any tokens exist at all. Information about failed session is at least providing some tip what to do.

But it happened that the problem is of broader scope. Well, as for technical reasons I boot from a non-persistent USB-stick the problem does not concern me long term at the moment unless it repeats, but I would not be surprised if it does.

(For example I constantly have some cookies related problem on mobile when I am thrown from desktop to mobile frontend and asked to enable cookies to get back (which are just as enabled as were before). I do not even know how to report as I can gather almost none information for reproducibility on mobile (for the record, ff for android, android kitkat))

I think the main purpose is to document that this occured so that if it happens again it won't be a single case.

If you feel like there is nothing to do here please close the task, it might be sensible at this point.

jmatazzoni added a subscriber: jmatazzoni.

It seems like the best solution here might be a better error message?

Framawiki updated the task description. (Show Details)Dec 2 2017, 12:44 PM
Framawiki added a subscriber: Framawiki.
Restricted Application added a project: Growth-Team. · View Herald TranscriptNov 21 2018, 2:17 PM
JTannerWMF closed this task as Declined.Jan 3 2019, 3:45 PM
JTannerWMF added a subscriber: JTannerWMF.

Author says we can close it if we want. This seems like a browser session issue related to author's setup.