Page MenuHomePhabricator

PHP DropdownInputWidget layout broken on Firefox 57
Closed, ResolvedPublic

Description

PHP DropdownInputWidget layout is broken on new Firefox 57/Quantum browser.


Event Timeline

Stryn created this task.Nov 9 2017, 2:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 9 2017, 2:26 PM
Reedy renamed this task from Delete reason dropdown box too high in 1.31.0-wmf.7 on Firefox Quantum to Delete reason dropdown box too tall in 1.31.0-wmf.7 on Firefox Quantum.Nov 9 2017, 2:55 PM
Reedy updated the task description. (Show Details)

"the new Firefox Quantum browser" = "Firefox 57"?

Legoktm renamed this task from Delete reason dropdown box too tall in 1.31.0-wmf.7 on Firefox Quantum to Delete reason dropdown box too tall in 1.31.0-wmf.7 on Firefox 57.Nov 9 2017, 5:55 PM
Legoktm edited projects, added OOUI, MediaWiki-HTMLForm; removed MediaWiki-Page-deletion.
Legoktm added a subscriber: Legoktm.

I can also see this on https://doc.wikimedia.org/oojs-ui/master/demos/demos.php? when using FF 57, so adding OOUI/HTMLForm.

Legoktm updated the task description. (Show Details)Nov 9 2017, 5:58 PM
Volker_E renamed this task from Delete reason dropdown box too tall in 1.31.0-wmf.7 on Firefox 57 to PHP DropdownInputWidget layout broken on Firefox 57.Nov 16 2017, 7:02 PM
Volker_E triaged this task as High priority.
Volker_E updated the task description. (Show Details)

Firefox 57 ignores this hack:

.oo-ui-dropdownInputWidget select:not( [ no-ie ] ) {  }

Change 391886 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[oojs/ui@master] PHP DropdownInputWidget: Firefox 57 ignores hack with whitespace

https://gerrit.wikimedia.org/r/391886

Change 391886 merged by jenkins-bot:
[oojs/ui@master] PHP DropdownInputWidget: Firefox 57 ignores hack with whitespace

https://gerrit.wikimedia.org/r/391886

Volker_E closed this task as Resolved.Nov 17 2017, 12:56 AM
Volker_E claimed this task.
Volker_E removed a project: Patch-For-Review.
Volker_E removed a subscriber: gerritbot.
Esanders added a subscriber: Esanders.EditedNov 17 2017, 5:03 PM

Looks like it will be fixed upstream soon. Will this affect any other rules in MediaWiki?

Change 392073 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/core@master] Work around Firefox 57 attribute parsing regression

https://gerrit.wikimedia.org/r/392073

Change 392073 merged by jenkins-bot:
[mediawiki/core@master] Work around Firefox 57 attribute parsing regression

https://gerrit.wikimedia.org/r/392073

@Esanders I've been only searching for the :not( [] ) combinations. As we write mostly backwards-compatible CSS code, this is the only one I'm aware of and could think of.
As you've probably seen yourself, when searching our codebase there's a third occasion at MobileFrontend/MinervaNeue with .captcha { input:not( [type='submit'] } . grunt-stylelint hasn't been updated to the latest version, therefore it didn't take effect in their current master. Have made @Jdlrobson & @bmansurov aware of the issue though.