Page MenuHomePhabricator

AdvancedSearch does not reliably show up on beta
Closed, DeclinedPublic

Description

On the beta cluster, when using the search input in the top right corner, you will be led to the Special:Search page, but every once in a while the remodeled advancedSearch is not visible.

Weirdly enough this does not happen on our test wiki

Event Timeline

Restricted Application added a project: TCB-Team. · View Herald TranscriptNov 10 2017, 10:28 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Addshore renamed this task from AdvancedSearch does not reliably show up to AdvancedSearch does not reliably show up on beta.Nov 10 2017, 10:52 AM
Addshore added a subscriber: Addshore.EditedNov 10 2017, 11:28 AM

@Lea_WMDE Per T180201 I have disabled AdvancedSearch on deployment.beta for now. Everything seems to be fine on all of the other beta sites de.wikipedia.beta etc.
I am guessing you were trying this out on deployment.beta
Could you please try and reproduce it on de.wikipedia.beta?

This is still happening on de.wikipedia.beta as well unfortunately @Addshore

WMDE-Fisch added a subscriber: WMDE-Fisch.EditedNov 10 2017, 1:24 PM

Hmm tried it about 30-40 times and it always worked for me. ... There is an error in the JS console showing each time. But it's not coming from any AdvSearch code. :-/

TypeError: mw.config.get(...)[namespace] is undefined

Edit: Linux, FF 56.0

Tried it several times (Chrome Version 62.0.3202.89 (Official Build) (64-bit)) on Windows 10 for beta.dewiki and I was not able to reproduce the issue.

So testing this today again I found that whenever AdvancedSearch does not show up, I also see a message that I am not logged in (although even the nav bar shows me as logged in). So I guess this might be more of a "can't find the beta feature, because can't see the person is logged in" problem.

(Testing on Mac OSX FF56.0)

I also see a message that I am not logged in

Where do you see this message?

although even the nav bar shows me as logged in

Do it should you as logged in straight away? or does it take a moment and then show as logged in?

I go from


to

(and the grey box on top tells me I am not logged in). So I am logged in, it might even have worked before, and then it doesnt (roughly every second time). However, when I wanted to respond to your post, I had to log out again, try a few time again, and only then I got the behavior again. It is not very consistent.

Lea_WMDE closed this task as Declined.Nov 13 2017, 12:34 PM

It looks like this has more to do with beta not realizing I am logged in (and thus not finding my beta preferences) than our stuff. We will keep an eye out on test, though

Tobi_WMDE_SW moved this task from Proposed to Done on the WMDE-QWERTY-Team board.Nov 14 2017, 1:30 PM
Tobi_WMDE_SW moved this task from Done to Demoed on the WMDE-QWERTY-Team board.Nov 14 2017, 3:09 PM

@Lea_WMDE T172560 is the ticket that essentially caused the behaviour you saw.