Page MenuHomePhabricator

UploadWizard stopped working after the latest MW updates
Closed, DeclinedPublic

Description

After MW 1.27 or so UploadWizard no longer works. There's a report here:

https://www.mediawiki.org/wiki/Extension_talk:UploadWizard#Wizard_stop_after_%22Release_rights%22

For me it stops on "Release Rights", showing a blank page under the headings. This is with MW 1.29.1, PHP 7.1.11 and UploadWizard 1.5.0 on Linux.

Same situation on a virtual machine running Linux Mint with PHP 7.0.22, MW 1.29.0 and UploadWizard 1.5.0 (dba3589).

Another setup with PHP 5.6.31, MediaWiki 1.26.2 and UploadWizard 1.4.0 works.

Event Timeline

Any javascript errors?

Any PHP errors in your logs?

Aklapper changed the task status from Open to Stalled.Nov 19 2017, 7:10 PM

I tried now with the latest git snapshot and it works, so I suppose you can disregard this report. Apologies for the inconvenience.

My first thought is that you did not upgrade UploadWizard after upgrading MediaWiki, and so it is no longer compatible with your MediaWiki. See https://www.mediawiki.org/wiki/Manual:Upgrading#Upgrade_extensions. You should download UploadWizard for MW 1.29 from https://www.mediawiki.org/wiki/Special:ExtensionDistributor/UploadWizard and try to use that.

I think the version number in UploadWizard has not been updated in several years, so "UploadWizard 1.5.0" doesn't really mean much :/

UploadWizard version dba3589 is compatible with MW 1.28, but not necessarily later versions (it's actually exactly the version that ExtensionDistributor would give you for 1.28, if that download was still available).

I noticed the minimum MW version required isn't updated too often either, I changed that from 1.25 to 1.27 earlier today to match what the extension distributor provides (>= 1.27).