Enable both "edit" and "edit code" tabs in Polish Wikipedia
Closed, ResolvedPublic0 Story Points

Description

On the basis of unanimous consensus of the Polish Wikipedia Community expressed in Kawiarenka techniczna (technical village pump) (permalink) and considering the fact that some of the largest Wikipedias have this option enabled, I hereby request to revert Single Edit Tab in Polish Wikipedia (T128477) and enable both "edit" and "edit code" tabs for non-logged users and logged users, who have not set "single edit tab" in their preferences.

Details

Wostr created this task.Nov 21 2017, 1:10 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 21 2017, 1:10 PM
Lothar added a subscriber: Lothar.Nov 23 2017, 8:08 AM

Change 393121 had a related patch set uploaded (by TerraCodes; owner: TerraCodes):
[operations/mediawiki-config@master] Remove single editor tab for plwiki

https://gerrit.wikimedia.org/r/393121

Deskana closed this task as Declined.Nov 28 2017, 5:34 PM
Deskana added a subscriber: Deskana.

I've taken a look at the discussion. There seem to be a few central points made, namely:

  1. Editors who return after a long time away from the site have a completely different editing experience.
  2. The ability to edit the wikitext is hard to find, and returning editors do not know how to get this experience.

Sadly, the premise of this discussion is incorrect. If an editor comes back after a long hiatus (specifically, from before 1 March 2016), and tries to edit, a dialogue is shown asking them which editing mode they want, and an "Always give me the wikitext editor" option is prominent.

Returning editors get to choose exactly what editing mode they want, including the option to never be shown the visual editor.

Regarding the other wikis that have the multiple edit tabs, the plan in the long run is to also migrate those wikis over to having a single edit tab. This plan is not actively being worked on right now due to other priorities, but that is still the long-term plan.

Based on above, I will not be carrying out this change, and am closing as declined.

Tufor added a subscriber: Tufor.EditedNov 28 2017, 10:02 PM

I am sorry but this is bullshit. I am no longer active on plwiki and wikimedia projects in general but after I saw this I thought I had to write somenthing. Dear @Deskana, why are you SINGLE-HANDEDLY rejecting UNANIMOUS(!!!) CONSENSUS of one of the LARGEST wiki-communities, you, as a WMF employee, were supposed to help with their problems in first place? I assume that you probably see experienced editors and administrators from plwiki who participated in that discussion as ignorant morons who don't know what's best for them and the wiki they edit and take care of daily. BUT YOU KNOW! You have your vision and anyone whose opinion differs from yours will be STRAIGHT OUT IGNORED. Well thank you, dear Deskana, for thinking and making decisions for ourselves! What would've we done without you?!

We do not ask to turn off VisualEditor or anything like that. We just want to have TWO tabs ("edit" and "edit source"), instead of ONE tab by default, which, funnily enough, LOADS VisualEditor to ask what editor you want to use (or at least did so back when I was active). Also, another funny thing: you picked these two points from our discussion and concluded that "OH WELL THE PREMISE IS INCORRECT" and completely omitted statements like KamilK's "If it wasn't for a source code editor at hand, I wouldn't have started my adventure with Wikipedia" (loosely translated). Most of people participating in that discussion didn't give their reasons for restoring two tabs, they just agreed with it. And it's not even surprising since we had many discussions in past dedicated to that but only now decided to create a task. Just look at some comments:

Barcival: "Tak nawiasem to kojarzę podobne dyskusje z przeszłości, wypowiadano się podobnie jak teraz, ale nikt zmiany nie wprowadził." ("By the way, I remeber similar discussions in a past, there were similar comments, but no one implemented any change")
Michał Sobkowski: "Za, jak wszyscy. Ale to już było. Czy ktokolwiek wie, jak to wcielić w życie? To jest kluczowe pytanie" ("For, like everybody. But it's been [discussed] already. Does anyone know how to implement it? That's the key question")
Gytha: "już kilkukrotnie wnioskowałam o domyślne dwa przyciski dla wszystkich" ("I've proposed for two tabs by default for everybody few times already")
So you can't say that the premise is wrong. The premise that YOU PICKED from this discussion may be wrong (but still, VE needs to be loaded in order to set the preferences).

You also say, regarding other wikis, that the long term plan is to have every wiki to hop on a single tab train. Well, can't our wiki, before this, according to you, inevitable, day of doom, have two edit tabs? Just like German Wikipedia. And French Wikipedia. And Italian Wikipedia. And many many more. Well, we don't know when will you finally make every wiki happy with a single tab by default, but can't we until then cherish these two sweet edit tabs that are going to be displayed next to each other? Are we undeserving? Are we worse? Or am I just too stupid to undestand why can't there be two tabs? If so, please explain it to me like I was three years old because there must be something wrong with my comprehension skills.

Every change can be reverted. We ask you to revert a "single edit tab" change. We want our editors to be free to choose which editor they want to use by having two tabs. Our community UNANIMOUSLY agreed on that. We want you to respect our decision. If you do not want to do it yourself, just let someone else do it.

Truly yours,
tufor

Wargo added a subscriber: Wargo.Nov 28 2017, 10:53 PM
Lothar removed a subscriber: Lothar.Nov 29 2017, 2:48 PM
Lothar added a subscriber: Lothar.

"Based on above, I will not be carrying out this change, and am closing as declined."

Rejecting large scale consensus like this...

Tufor reopened this task as Open.Dec 1 2017, 5:35 PM

Re-opening, since in three days time neither Deskana (who has been active here on Phabricator) nor anyone else bothered to reply and provide valid reasons to decline this request.

Krenair added a subscriber: Krenair.Dec 2 2017, 8:06 PM
Masti added a subscriber: Masti.Dec 3 2017, 8:11 PM

I'm disappointed that this change was forced through by a user adding some code to common.js despite my pointing out that the description of the poll was not based on facts.

I had the code that was added to common.js evaluated by an engineer. It does not appear cause any obvious security or performance problems right now. However, it is incredibly hacky, and it will almost certainly break at some point in the future, interfering with the editing experience. It also causes user interface elements to shift around on every page load due to adding elements using JavaScript late in the loading process, which presents a bad experience.

So, here are my choices.

The first choice is that I continue to refuse to implement this because the poll was based on falsehoods. This choice will have negative consequences for all anonymous and some logged in editors due to shifting interface elements, and likely cause significant disruption in the editing experience at some point in the future when the code inevitably breaks.

The second choice is that I implement this properly despite trying to point out that the premise of the poll was quite obviously false. It's a step back in terms of user experience, but at least it avoids the negative consequences for users now and in the future which were caused by the user who added the hacky code to common.js.

I really have no choice but to go for the second option, implement what the poll wants despite it being based on falsehoods, and try to avoid the problems that the hacky code added to common.js are causing and will cause in the future. I repeat what I said above: the plan in the long run is to migrate all wikis over to having a single edit tab. It's not being actively pursued, but it will happen eventually.

I'm quite frankly embarrassed by this whole ordeal. Apparently it's acceptable behaviour to create polls based on falsehoods, refuse to listen when someone points out that the premise of the poll is false, be uncivil to staff because they disagreed with you, and force through hacky code to get what you want. This is a definite low point in my twelve years as a Wikimedian. I hope that it's been worth it.

Wargo added a comment.Dec 14 2017, 4:52 PM

Sadly, the premise of this discussion is incorrect. If an editor comes back after a long hiatus (specifically, from before 1 March 2016), and tries to edit, a dialogue is shown asking them which editing mode they want, and an "Always give me the wikitext editor" option is prominent.

Problem is VisualEditor is loaded first, taking a while, and then dialog is shown.

Change 393121 merged by jenkins-bot:
[operations/mediawiki-config@master] Remove single editor tab for plwiki

https://gerrit.wikimedia.org/r/393121

Mentioned in SAL (#wikimedia-operations) [2017-12-14T19:20:23Z] <thcipriani@tin> Synchronized wmf-config/InitialiseSettings.php: SWAT: [[gerrit:393121|Remove single editor tab for plwiki]] T181045 (duration: 01m 09s)

Deskana closed this task as Resolved.Dec 14 2017, 7:24 PM
Deskana set the point value for this task to 0.

The config change has now been deployed. The code on common.js is no longer needed. Unfortunately, that hacky code is now misbehaving, and labelling both tabs as "edit source". I'm going to remove it.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptDec 14 2017, 7:24 PM

I removed the code from common.js, and the tabs are now correctly labelled.

Wostr added a subscriber: Alsee.Dec 14 2017, 7:58 PM

@Deskana As a person who placed here this request, I feel obligated to clarify a few issues. Firstly, I'm truly sorry that there were comments in this thread from Polish Wikipedia contributors which were uncivil and very emotional. This is not the way the discussion should be conducted, nor is it the way that is accepted here or in Polish Wikipedia. However, the fact is that many people were deeply disappointed by this decision and the rejection of unanimous consensus was met with general incomprehension. It also deepened the division between project volunteers and WMF staff, while also increasing the negative attitude towards WMF activities.

The lack of two edit tabs is a recurring issue in Polish Wikipedia. The discussion linked in the request is one of many. One of such discussions was brought here by @Alsee in Febraury this year (T159032) and it was rejected (quite correctly, as there were no wide consensus at that time, which is required by our local policies; also, it was about performance issue, so it should be solved by fixing the problem in the first place, not by reverting two tabs). The issues indicated by @Wargo above or by yourself from the linked discussion are just single issues from many more. And it's not simple to point out all of them here one by one, as many of them are not just ordinary technical problems, but rather opinions or vision of how the project should work and what is best for editors.

The main reason for this change can be described as follows: every contributor should have access to both editors on an equal basis (unless one decides to choose single editor in ones preferences) and the current situation, when contributor is asked to choose editor only once and usually he's not aware about differences between editors (and also the switching between editors is unintuitive for non-technical and inexperienced contributors) is not acceptable. What's more, current setting clearly prefers the use of VisualEditor and many of the Polish Wikipedia contributors thinks that this editor should not be preffered in any way by the interface or by technical settings, as the code editor is still the main editor used on this wiki.

Issues like technical problems, long loading time of VE, refrain from editing caused by the suggestion that the whole editor has changed, and many more are IMHO less important problems, but still problems that affect some part of Polish Wikipedia Community. My fault in this case is that I did not point out any arguments for this change apart from consensus of the Community. I was hoping that it's enough for such change to be implemented, but clearly I was wrong.

As I see now, that some changes has been made (I've started writing this before today's comments), I can only add that various steps were considered after the initial declining of this task, including local interface changes and asking the WMF through Polish Wikimedia Chapter. Implementation of the local changes was sufficient to achieve desired effect and in light of the initial decision in this thread, it was completely justified from my point of view.

Given that this request has been resolved, I can only thank you for implementing this change.

Misunderstanding. This disabled the whole feature. We asked to have two tabs by default for not logged in. Users can't now set SET in their preferences.

We don't have an option in site configuration to do that right now. The options are:

  • $wmgVisualEditorUseSingleEditTab = false: two tabs, "Edit" and "Edit source", are always displayed (except on pages that can't be edited with VE)
  • $wmgVisualEditorUseSingleEditTab = true: user has an option in preferences to choose whether to use the above behavior, use only VE, use only WT, or use whichever editor they used last (this is the default choice).

It could be possible to add an option identical to $wmgVisualEditorUseSingleEditTab = true, but with the two-tab behavior as the default, but I am not comfortable writing that and getting it deployed in the very last deployment window before the new year (https://wikitech.wikimedia.org/wiki/Deployments).

If this is important (and I'm not sure if it is, I see only one complaint about it in the on-wiki discussion right now), please remind us on the 2nd of January :)

It is nice to hear from you, @Wostr. :-)

@Deskana As a person who placed here this request, I feel obligated to clarify a few issues. Firstly, I'm truly sorry that there were comments in this thread from Polish Wikipedia contributors which were uncivil and very emotional. This is not the way the discussion should be conducted, nor is it the way that is accepted here or in Polish Wikipedia.

Thank you. That's nice to hear.

However, the fact is that many people were deeply disappointed by this decision and the rejection of unanimous consensus was met with general incomprehension. It also deepened the division between project volunteers and WMF staff, while also increasing the negative attitude towards WMF activities.

I agree. However, this works both ways. I spend eight hours a day working on editing projects, and it's quite disheartening when a poll like this happens and I'm only told after it's finished. It would've been much better if I could've pointed out the flaws in it right from the start, for example, then this situation could've been avoided. That furthers the divide as well.

So, I guess my point is, WMF staff further this divide sometimes, but so do the communities. Often, it's unintentional, and it probably was here too. It helps for staff and communities alike to consider this. I don't think is something you and I can solve on our own, obviously.

The lack of two edit tabs is a recurring issue in Polish Wikipedia. The discussion linked in the request is one of many. One of such discussions was brought here by @Alsee in Febraury this year (T159032) and it was rejected (quite correctly, as there were no wide consensus at that time, which is required by our local policies; also, it was about performance issue, so it should be solved by fixing the problem in the first place, not by reverting two tabs). The issues indicated by @Wargo above or by yourself from the linked discussion are just single issues from many more. And it's not simple to point out all of them here one by one, as many of them are not just ordinary technical problems, but rather opinions or vision of how the project should work and what is best for editors.

That makes sense. It's difficult for me since I've been working on this for only six months and am not aware of much of the history. Unless the history is laid out for me, I have to focus on what's right in front of me, like I did with this poll.

As an aside, I heard and understood the performance issues, and they are being actively worked on. Just a few days ago, my team merged some code which attempts to measure performance more comprehensively so we understand it better.

The main reason for this change can be described as follows: every contributor should have access to both editors on an equal basis (unless one decides to choose single editor in ones preferences) and the current situation, when contributor is asked to choose editor only once and usually he's not aware about differences between editors (and also the switching between editors is unintuitive for non-technical and inexperienced contributors) is not acceptable. What's more, current setting clearly prefers the use of VisualEditor and many of the Polish Wikipedia contributors thinks that this editor should not be preffered in any way by the interface or by technical settings, as the code editor is still the main editor used on this wiki.

I understand. My own testing shows that the performance issues are not nearly as bad as people claim they are, but in reality neither you nor I have anything other than anecdotal evidence to prove our claims. I hope that the data my team is going to gather will help us figure that out properly.

Issues like technical problems, long loading time of VE, refrain from editing caused by the suggestion that the whole editor has changed, and many more are IMHO less important problems, but still problems that affect some part of Polish Wikipedia Community. My fault in this case is that I did not point out any arguments for this change apart from consensus of the Community. I was hoping that it's enough for such change to be implemented, but clearly I was wrong.

Mistakes were made. It happens. What matters most is that we try to work together better in the future. :-)

As I see now, that some changes has been made (I've started writing this before today's comments), I can only add that various steps were considered after the initial declining of this task, including local interface changes and asking the WMF through Polish Wikimedia Chapter. Implementation of the local changes was sufficient to achieve desired effect and in light of the initial decision in this thread, it was completely justified from my point of view.

It wasn't justified at all from where I'm standing, but we don't need to go back and forth on that. You and I have both explained our viewpoints. Let's move on and try to work together in the future.

Given that this request has been resolved, I can only thank you for implementing this change.

I don't think I deserve your thanks considering I didn't want to do this, but I appreciate it nevertheless.

Misunderstanding. This disabled the whole feature. We asked to have two tabs by default for not logged in. Users can't now set SET in their preferences.

As @matmarex said, this is not possible with the current configuration options. It is something that can be considered after the holidays, as deployments are not allowed now.

Halibutt added a subscriber: Halibutt.EditedDec 20 2017, 8:35 AM

One note: the consensus at pl.wiki was to enable both edit tabs for logged-in users (that was the original question), not for anonymous users. Some users postulated that, some didn't, hard to judge.

The original question was

Czy nie można ustawić domyślnie obu zakładek dla użytkowników zalogowanych?

That is

Is it possible to enable both edit tabs for logged-in users by default?

That's the option people were voting for.

Lothar removed a subscriber: Lothar.Dec 20 2017, 9:24 AM