Page MenuHomePhabricator

When you edit a section, the URL should include a link to the section
Closed, ResolvedPublic1 Estimated Story Points

Description

What happens:

  1. Edit a section on a talk page.
  2. Save page.
  3. Now you need to put a link to that section in a Phab task. Check the URL. See https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical) with no link to the section itself.
  4. Scroll all the way up to the Table of Contents.
  5. Find and click the right section.
  6. Now copy the new, complete URL, which now contains a #link to the correct section.

What should happen:

  1. Edit a section on a talk page.
  2. Save page.
  3. Copy the complete URL, which already has the needed #link to the correct section.

Event Timeline

Restricted Application added a project: VisualEditor. · View Herald TranscriptNov 21 2017, 6:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Deskana triaged this task as Medium priority.Nov 21 2017, 7:33 PM
Deskana moved this task from To Triage to TR1: Releases on the VisualEditor board.
Deskana set the point value for this task to 1.
Deskana added a subscriber: Deskana.

Yes, it should.

Change 398285 had a related patch set uploaded (by Esanders; owner: DLynch):
[mediawiki/extensions/VisualEditor@master] Add section id to URI fragment on save

https://gerrit.wikimedia.org/r/398285

Change 398285 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Add section id to URI fragment on save

https://gerrit.wikimedia.org/r/398285

Deskana closed this task as Resolved.Dec 18 2017, 12:37 PM
Deskana assigned this task to DLynch.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptDec 18 2017, 12:37 PM
Ryasmeen edited projects, added Verified; removed Patch-For-Review.Jan 3 2018, 11:36 PM
Ryasmeen reopened this task as Open.Jan 3 2018, 11:57 PM
Ryasmeen removed a project: Verified.
Ryasmeen added a subscriber: Ryasmeen.

This is still reproducible on Firefox

DLynch added a comment.Jan 5 2018, 5:55 PM

It's not Firefox, per-se. Rather it's related to the query in the URL. I didn't notice this happening because I was always testing with debug=true in mine, which made this not happen. Patch in a second.

Change 402399 had a related patch set uploaded (by DLynch; owner: DLynch):
[mediawiki/extensions/VisualEditor@master] Use section fragment after-save even if the query is empty

https://gerrit.wikimedia.org/r/402399

Change 402399 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Use section fragment after-save even if the query is empty

https://gerrit.wikimedia.org/r/402399

Ryasmeen closed this task as Resolved.Jan 12 2018, 5:59 PM
Ryasmeen edited projects, added Verified; removed Patch-For-Review.