Page MenuHomePhabricator

On some wikis, #jump-to-nav elements on Recent changes are overlapping the page title
Closed, ResolvedPublic

Description

To navigate on the Recent Changes page, you can use the keyboard to access quickly some specific navigation links.

How to:

  1. load Recent Changes page on fr.wp or de.wp (not en.wp where the case can't be reproduced)
  2. press Tab

Expectation:

Reality:

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptNov 22 2017, 2:55 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

What is #jump-to-nav? It must be something you add somehow, since I don't see it on fr or de.

It is a native navigation element., you have it on any page.

Yes, the element is present, but not in UI (unless not on my screen. Some gadget needs to be enabled?):

<div id="jump-to-nav" class="mw-jump">
					Jump to:	
<a href="#mw-head">navigation</a>, <a href="#p-search">search</a>
				</div>

#jump-to-nav is only displayed when JS is disabled IIRC.

We see this on French but not English, for example. Why? What customization did French do to the page?

During the bug triage meeting the bug was confirmed - the issue exists on Watchlist too (RelatedChanges page seems to be ok).

#jump-to-nav is only displayed when JS is disabled IIRC.

I see those links when I use Tab keyboard as described in the task description.

We see this on French but not English, for example. Why? What customization did French do to the page?

As described on the task, the issue is true for fr and also de. I've tried again on Spanish Wikipedia, and I have that issue there as well.
You should question the opposite here: what customization did English Wikipedia not to have those links. :)

Change 403203 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/core@master] Fix jump-to-nav element overlap on RCFilters

https://gerrit.wikimedia.org/r/403203

Petar.petkovic added a subscriber: Petar.petkovic.

You should question the opposite here: what customization did English Wikipedia not to have those links. :)

You are right, sir. Because of T178626, following code was added to Common.css file on enwiki:

/* T178626 */
#contentSub:empty,
#contentSub2:empty {
    display: block !important;
}

#contentSub:empty ~ #jump-to-nav,
#contentSub2:empty ~ #jump-to-nav {
    margin-top: -1.4em !important;
    margin-bottom: 1.4em !important;
}

which makes this bug not appear on enwiki, although the reason for adding this piece of code was different issue.

@Petar.petkovic, is you change making the English Wikipedia hack obsolete?

@Petar.petkovic, is you change making the English Wikipedia hack obsolete?

English Wikipedia hack is added for different reasons than what's described in this ticket, but affects RC pages as well, making navigation not overlapping with the title.
I have provided solution with enwiki and all other wikis in mind, so nothing breaks because of custom overrides afterwards.

If you need to change English Wikipedia's CSS, because of any good reason (conflict with your patch, redundancy...) that will not affect their experience, that's possible.

Change 403203 merged by jenkins-bot:
[mediawiki/core@master] Fix jump-to-nav element overlap on RCFilters

https://gerrit.wikimedia.org/r/403203

Etonkovidova closed this task as Resolved.Feb 13 2018, 5:26 PM

Checked in wmf.20 for frwiki and dewiki - the links are displayed correctly.