[wmf.8-minor] 'New translation' search displays previous language selection in the warning "No pages found for ..."
Closed, ResolvedPublic

Description

  1. On the Content translation page click on 'New translation'
  2. Enter the search criteria that cannot be found in the selected language; you may use some random string of characters.
  3. The user message appears informing you that e.g. " No pages found for "443j24p3d" in English".
  4. Select a different language - the selection will be changed, but the message will not be changed: " No pages found for "443j24p3d" in English"


Note: The issue is minor - if a page is found, all the suggestions will be displayed correctly according to the newly selected language.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 28 2017, 12:44 AM

Change 394492 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Fix no result messages on "New translation" dialog

https://gerrit.wikimedia.org/r/394492

Change 394492 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Fix no result messages on "New translation" dialog

https://gerrit.wikimedia.org/r/394492

Checked in cx-testing - the fix works according to the description in https://gerrit.wikimedia.org/r/394492.

Etonkovidova closed this task as Resolved.Jan 2 2018, 2:15 AM
Petar.petkovic moved this task from QA to Done on the Language-2017-Oct-Dec board.Jan 2 2018, 2:23 AM