Page MenuHomePhabricator

Some BSicon SVG files that don't define a namespace on Commons fail to load, their PNG thumbnail have a HTTP 429 error
Closed, DeclinedPublic

Description

Some of the BSicon files are not loading properly, causing mayhem on the en:Wikipedia canal maps. So far I have found File:BSicon_uSTAIRd.svg, File:BSicon_uFGATEd.svg and File:BSicon_uFGATEu.svg.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 28 2017, 2:05 PM

Hi @Bob1960evens, thanks for taking the time to report this!
Unfortunately this report lacks some information. If you have time and can still reproduce the problem: Please add a more complete description to this report (a list of steps to reproduce which leave no room for interpretation what to do, describing actual results and expected results after performing the steps to reproduce, attaching or linking to a public testcase, etc). You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

Where to see "en:Wikipedia canal maps"? Is this maybe about BlueSpice (because of the "BS")?

Ah. It seems like this all refers to names of images hosted on Wikimedia Commons!
Alright, let's see:

Indeed there are issues with those files not being displayed. Thanks for reporting this!

Aklapper renamed this task from BSicon files fail to load to Some BSicon SVG files on Commons fail to load, their PNG thumbnail have a HTTP 429 error.Nov 29 2017, 9:51 AM
Aklapper added projects: Thumbor, media-storage.

HTTP 429 error for the thumbnails in PNG format.
The SVG files themselves also do not display in Firefox or Chromium: https://upload.wikimedia.org/wikipedia/commons/c/ce/BSicon_uFGATEu.svg

This reminded me of T170109 but that's not the case here. That SVG is rather simple:

<svg width="500" height="500" viewBox="0 0 500 500">
<title>
 BS: Locks3
</title>
<g fill="none" transform="translate(250,250) rotate(180) translate(-250,-250)">   
<rect width="100" height="500" x="200" y="0" style="fill:#039" />
<polyline points="100,175 250,275 400,175" stroke-width="40" stroke="#FFFFFF" />
<polygon points="110,158 200,218 200,265 90,192 110,158" style="fill:rgb(0,0,0);stroke-width:1;stroke:rgb(0,0,0)" />
<polygon points="300,218 300,265 410,192 390,158 300,218" style="fill:rgb(0,0,0);stroke-width:1;stroke:rgb(0,0,0)" />
</g>
</svg>

Oh, might also be the missing namespace in those files? See T43174#454125
So this might be a WONTFIX / declined as those files need fixing.

Aklapper renamed this task from Some BSicon SVG files on Commons fail to load, their PNG thumbnail have a HTTP 429 error to Some BSicon SVG files that don't define a namespace on Commons fail to load, their PNG thumbnail have a HTTP 429 error.Nov 29 2017, 9:54 AM
Gilles closed this task as Declined.Nov 29 2017, 1:56 PM
Gilles added a subscriber: Gilles.

Indeed, the namespace is necessary. I don't think we should be more permissive than browsers.

Since BSicon_uFGATEd.svg has been displaying correctly since May 2008, and the 38 pages that use it are now broken, how does it get fixed? I have tried adding stuff to the start of the file, in line with others that are still working, but it resolutely fails to display on Commons, or on any of the pages that use it on en:Wikipedia.

Ah, I think it must just take a long time after uploading a new file fore commons shows it.