Flow: Better error handling on unexpected responses is needed
Open, Needs TriagePublic

Description

I'm getting the following mysterious red blob when I attempt to make a comment on this wiki at a client:

This happens if I open a comment and begin to respond, but my session in the proxy that handles all requests times out.

Going into the dev tools to try and understand what is going after I hit reply ends up with this response to the POST that Flow sends:

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptNov 28 2017, 4:52 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

To clarify: did you install Flow without installing EventLogging? Not that that should break, but maybe it does, and that's causing (part of) your problems?

Restricted Application added a project: Growth-Team. · View Herald TranscriptNov 21 2018, 2:17 PM
kostajh moved this task from Inbox to To Triage on the Growth-Team board.Nov 27 2018, 3:00 PM
JTannerWMF closed this task as Invalid.EditedThu, Jan 3, 3:44 PM
JTannerWMF added a subscriber: JTannerWMF.

No follow up since author filed it a year ago

MarkAHershberger reopened this task as Open.Thu, Jan 3, 5:31 PM

@Catrope: I did not install EventLogging. I don't think that is related to the timeout issue, though.

No, I don't think it's directly related to the timeout issue, but from your console screenshot I do think that a JS error (caused by an assumption that EventLogging is available while it's not) prevented the error from being rendered. Confusingly, I can't find mw.eventLog or .schemas anywhere in the Flow code base, neither now nor at the time that you filed the bug, so I don't know where the error (or the assumption that EventLogging is installed) comes from.

If you can still reproduce this error, I would recommend installing EventLogging (even if it points nowhere) in the hopes of getting through to the actual error. In the alternative, having the full stack trace of the mw.eventLog.schemas error would be helpful (only the first line of it is visible in the screenshot before it cuts off), and having the API response for the attempted save (which can be obtained through the Network tab in the inspector) would be too.

Catrope moved this task from To Triage to Q3 2018-19 on the Growth-Team board.Fri, Jan 11, 11:47 PM