Page MenuHomePhabricator

Put a "clear cache" button to renew statistics
Closed, ResolvedPublic

Description

Sometimes we have an edit-a-thon or an event we want to track and give live data on what we have been doing (imagine, a press-release) but the course data is not renewed on-the-fly (currently, 3 days lag for updating). It would be great to have a button to refresh cache on a given course.

PD: Or maybe there is!

Event Timeline

Theklan created this task.Nov 29 2017, 3:42 PM
Restricted Application added subscribers: Base, Aklapper. · View Herald TranscriptNov 29 2017, 3:42 PM
Theklan renamed this task from Put a "clear cache" to renew statistics to Put a "clear cache" button to renew statistics.Nov 29 2017, 3:42 PM

Thanks for the /manual_update clue, by the way!

Ogoletti added a subscriber: Ogoletti.EditedNov 30 2017, 8:36 AM

Hi there,

I have the same issue with my program here : https://outreachdashboard.wmflabs.org/courses/UCL/Venez_Contribuer
If you look under the stats, one can read 'According to the last system update. Last update: 4 days ago'
I tried the /manual_update link but got a '500 — internal server error. :-(' though. Is this normal ?

Thanks,

O.

Yes, it seems that is not refreshing now.

Thanks for posting, @Ogoletti. I've been digging into the problem this morning, and I think I may have found the cause. There are 400,000 articles in active programs that is trying to refresh stats for every cycle, and that caused a database bottleneck that I hadn't considered. Hopefully I'll have it back on track later today.

-Sage

@Ogoletti @Theklan I got the update problem sorted out. Should be back to updating every 4-5 hours now.

Ragesoss closed this task as Resolved.Apr 23 2019, 9:58 PM
Ragesoss claimed this task.