Page MenuHomePhabricator

Advanced Search: Namespace Filters not working in dewiki
Closed, ResolvedPublic

Description

Advanced Search on deWikipedia seams to always search in Article-Namespace no matter wich namespace has been selected.
This issue occures only on some accounts; it occures when the URL-parameter "profile=default" is set by the search.

Example-URL

Event Timeline

Restricted Application added a project: TCB-Team. · View Herald TranscriptNov 29 2017, 4:18 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Lea_WMDE triaged this task as Unbreak Now! priority.Nov 30 2017, 10:25 AM
Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptNov 30 2017, 10:25 AM

Looks like I can reproduce this one locally.

The issue is profile default is used, so the namespace options are not loaded, when profile advanced should be used, which would load the namespaces.

Change 394276 had a related patch set uploaded (by Addshore; owner: Addshore):
[mediawiki/extensions/AdvancedSearch@master] Force search profile advanced

https://gerrit.wikimedia.org/r/394276

Addshore moved this task from Sprint Backlog to Review on the WMDE-QWERTY-Sprint-2017-11-28 board.
Restricted Application added a project: User-Addshore. · View Herald TranscriptNov 30 2017, 11:23 AM
Addshore moved this task from Proposed to Currently in sprint on the WMDE-QWERTY-Team board.

Change 394276 merged by jenkins-bot:
[mediawiki/extensions/AdvancedSearch@master] Force search profile advanced

https://gerrit.wikimedia.org/r/394276

Change 394297 had a related patch set uploaded (by Addshore; owner: Addshore):
[mediawiki/extensions/AdvancedSearch@wmf/1.31.0-wmf.10] Force search profile advanced

https://gerrit.wikimedia.org/r/394297

Change 394299 had a related patch set uploaded (by Addshore; owner: Addshore):
[mediawiki/extensions/AdvancedSearch@wmf/1.31.0-wmf.8] Force search profile advanced

https://gerrit.wikimedia.org/r/394299

Change 394297 merged by jenkins-bot:
[mediawiki/extensions/AdvancedSearch@wmf/1.31.0-wmf.10] Force search profile advanced

https://gerrit.wikimedia.org/r/394297

Change 394299 merged by jenkins-bot:
[mediawiki/extensions/AdvancedSearch@wmf/1.31.0-wmf.8] Force search profile advanced

https://gerrit.wikimedia.org/r/394299

Mentioned in SAL (#wikimedia-operations) [2017-11-30T13:22:37Z] <addshore@tin> Synchronized php-1.31.0-wmf.8/extensions/AdvancedSearch/modules/ext.advancedSearch.init.js: pre-swat: T181644 Force search profile advanced in AdvancedSearch [[gerrit:394299]] (duration: 00m 50s)

Mentioned in SAL (#wikimedia-operations) [2017-11-30T13:23:41Z] <addshore@tin> Synchronized php-1.31.0-wmf.10/extensions/AdvancedSearch/modules/ext.advancedSearch.init.js: pre-swat: T181644 Force search profile advanced in AdvancedSearch [[gerrit:394297]] (duration: 00m 48s)

Addshore closed this task as Resolved.Nov 30 2017, 1:24 PM

Backports for this issue done and it looks like it is working everywhere for me now.

HOWEVER, if you click the link in the description of this task you'll initially see the same behaviour. Clicking search again will then have the correct behaviour from advancedsearch.

Addshore moved this task from Review to Done on the WMDE-QWERTY-Sprint-2017-11-28 board.

I had the problem before, but now it works with different namepaces. Thanks, @Addshore!

Lea_WMDE moved this task from Done to Demoed on the WMDE-QWERTY-Team board.Feb 20 2018, 3:32 PM