Page MenuHomePhabricator

iOS app users in California seeing both US and Canada banners
Closed, ResolvedPublic

Description

Hey all, thanks for getitng the announcement up and running.

Both @cmadeo and I are seeing both the US and Canada announcements. Not sure if there is much we can do about this given the timing and the fact that this might just be an IP lookup issue, but I thought it was worth filing for potential investigation/future.

Device: iPhone 6S
iOS: 11.1
App version: 5.7.2 (current internal build)
IP address: 98.248.238.16

Details

Related Gerrit Patches:
mediawiki/services/mobileapps : masterRevert "Update: exclude Canada from iOS countries list"
mediawiki/services/mobileapps : masterUpdate: exclude Canada from iOS countries list

Event Timeline

JMinor created this task.Nov 30 2017, 7:07 PM

Must be a client issue. The endpoint response looks correct.

bearND removed bearND as the assignee of this task.Nov 30 2017, 7:21 PM
bearND added a subscriber: bearND.

I'm not sure I can help here except make a change to the announcement to turn it off for Canada or something similar.
It really depends on how the iOS app implemented this feature. (I did check on a friend's iPhone here, and I only see the US version here).
FWIW, here's the Android version of this logic. Here's the live JSON for the announcements: https://en.wikipedia.org/api/rest_v1/feed/announcements.

Thanks guys. Its definitely not everyone on iOS (out of 6 people in the meeting, 2 had this issue, both located in SF). I'll check OTRS this afternoon, but unless people are complaining I'm inclined to leave this on just as is, and look into a bit on iOS side.

bearND added a comment.EditedNov 30 2017, 7:38 PM

Ok, I have a theory. If my theory is correct then most, if not all, California iOS app users would be affected. :(
Was everybody in your meeting located in California? Or only the two that saw the double announcements and the others not? If it's the former then my theory is probably wrong, if it's the latter it becomes more likely to be very close.

The cookie header starts with this in California (CA)

Set-Cookie: GeoIP=US:CA;....

A Canadian user would get something like this:

Set-Cookie: GeoIP=CA:BC:...

So, both have CA, just in different GeoIP fields.

Here's the iOS code: https://github.com/wikimedia/wikipedia-ios/blob/c3edc175a92991846f4eea843b9bc134031d82b3/WMF%20Framework/WMFAnnouncementsFetcher.m#L79
The issue is that the iOS implementation looks at the whole string and not just the country field.
It could also be a few lines below that. Hard for me to say without a debugger and not enough ObjectiveC experience.

I could turn off the announcements for iOS for all countries or select countries if you'd like.

Okay @JoeWalsh has confirmed this is indeed the issue. We actually had a bugfix release planned for the next few days, so we'll patch this in the client and move that into the store asap. Until then, I suggest we leave the backend as is, so that we can test the fix, etc. Its embarassing for a couple days in California, but it doesn't break any functionality or keep you from donating.

Per this and recent convos with @Fjalapeno I think we'll need to iterate on how we plan, test and target announcements to give ourselves a bit more breathing room before next year's fundraising season.

JMinor renamed this task from Some iOS users seeing US and Canada banners to iOS app users in California seeing both US and Canada banners.Nov 30 2017, 8:27 PM
JMinor added a project: iOS-app-v5.7.2.

Per this and recent convos with @Fjalapeno I think we'll need to iterate on how we plan, test and target announcements to give ourselves a bit more breathing room before next year's fundraising season.

... or for any other announcements. It would be helpful to communicate announcement requests much earlier.

It would be helpful to communicate announcement requests much earlier.

Agreed, this is mostly on me. Fundraising gave plenty of notice, and I was just not following through and keeping an eye on it early enough :(

@JMinor The fundraising team just discussed this. Given the volume of app use in California, and the comparatively small number of donations we expect from Canada, we're totally fine if you want to turn off the announcements in Canada until the client can be fixed.

I think we might have missed the deploy window... @bearND is it still
possible to change the endpoint? Maybe just set the start date for iOS
Canada for a week from today? By then the update should be well out.

Change 394440 had a related patch set uploaded (by Mholloway; owner: Mholloway):
[mediawiki/services/mobileapps@master] Update: exclude Canada from iOS countries list

https://gerrit.wikimedia.org/r/394440

Change 394440 merged by jenkins-bot:
[mediawiki/services/mobileapps@master] Update: exclude Canada from iOS countries list

https://gerrit.wikimedia.org/r/394440

Mentioned in SAL (#wikimedia-operations) [2017-11-30T23:14:05Z] <bsitzmann@tin> Started deploy [mobileapps/deploy@4305d96]: Update mobileapps to 4317ea5 (T181743)

Mentioned in SAL (#wikimedia-operations) [2017-11-30T23:18:55Z] <bsitzmann@tin> Finished deploy [mobileapps/deploy@4305d96]: Update mobileapps to 4317ea5 (T181743) (duration: 04m 50s)

cache purged as of :31 past the hour.

@Pcoombe @bearND @JMinor @Mholloway

Thanks for handling this so professionally 🙌, that was a nasty one to identify 👀. Looking forward to getting it up again in Canada next week!

JMinor added a comment.Dec 7 2017, 8:28 PM

Hey all, the version of the app with the Canada fix is now released (we ran into an unrelated issue in testing which added a couple days). This means we can probably re-activate the Canada announcement early next week. I'll confirm tomorrow afternoon that updates have/are happening, but I think we should be ready in a few days.

Change 397547 had a related patch set uploaded (by Mholloway; owner: Mholloway):
[mediawiki/services/mobileapps@master] Revert "Update: exclude Canada from iOS countries list"

https://gerrit.wikimedia.org/r/397547

Change 397547 merged by Joewalsh:
[mediawiki/services/mobileapps@master] Revert "Update: exclude Canada from iOS countries list"

https://gerrit.wikimedia.org/r/397547

Mholloway closed this task as Resolved.Dec 13 2017, 10:25 PM
Mholloway claimed this task.