Page MenuHomePhabricator

Anonymous 3G speed indices fluctuating by 2000 on the en.wiki Barack Obama article starting on November 30th, 17:00
Closed, ResolvedPublic

Description

The 3G speed indices are bouncing up and down from a baseline 2000 prior to November 30th to around 4000. Prior to that, they were pretty stable. This is most likely due to fund raising.

https://grafana.wikimedia.org/dashboard/db/mobile-2g?orgId=1&from=now-30d&to=now

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 6 2017, 3:59 PM

Fundraiser related?

Niedzielski updated the task description. (Show Details)Dec 11 2017, 4:05 PM

Confirmed that fundraising went live for mobile at ~16:00UTC on 11/30 -- from IRC logs:

[16:07:13] <pcoombe>	 Heads up MBeat et al, we just launched mobile and ipad

Feel comfortable with that explanation, @Niedzielski ?

Peter added a subscriber: Peter.Dec 11 2017, 8:54 PM
Peter added a comment.EditedDec 11 2017, 9:07 PM

Here are some screenshot for Facebook:
http://wpt.wmftest.org/video/compare.php?tests=171211_Z5_NK,171209_2Z_Q9,171209_Q4_64,171207_DR_F

That 5th run is the one with the hight speed index and fundraising as @Imarlier said.

One side note: I've checked a couple of screenshots for Obama and we have tests where we do not load the Obama image, I can dig into that later this week (because it is not a feature right?):
http://wpt.wmftest.org/video/compare.php?tests=171211_1A_MF,171211_QB_C7,171211_MP_9T,171211_YH_8J,171211_8Y_67,171211_2N_3R,171211_ER_2G,171211_JN_19

I've checked a couple of screenshots for Obama and we have tests where we do not load the Obama image [..]
http://wpt.wmftest.org/video/compare.php?tests=171211_1A_MF,171211_QB_C7,171211_MP_9T,171211_YH_8J,171211_8Y_67,171211_2N_3R,171211_ER_2G,171211_JN_19

Yeah, more specifically, it seems that in some cases the order of the opening paragraph and infobox are reversed. In the original DOM, the right-floating infobox is before the opening paragraph (as otherwise it can't float on top-right). But mobile has a feature flag for hoisting the first paragraph to higher in the DOM. I don't know what the current state is of that feature and/or whether it is actively being tested or always on/off in Beta.

Default (infobox-first), image not yet loadedImage and banner loaded
paragraph-first
Niedzielski closed this task as Resolved.Dec 12 2017, 2:26 PM

Thanks for looking in to this @Imarlier, @Peter, @Krinkle. I'll close this out.

Regarding the lead image not loading, I think that's test specific. Our release timeline, T150325, and mediawiki-config show the lead paragraph shifting deployment to stable across projects completing in May. T170006 isn't out yet AFAIK. All of the examples with images I see on the tests are using a test banner. e.g.:

(Test banner two (CentralNotice))

And here's what I see on enwiki at the moment:

(Large banner)
(Fullscreen pop-up)
(Original)

https://phabricator.wikimedia.org/T182200#3829560

Why is "Hello" the lead paragraph? Vandalism? In both these examples there is a lead paragraph above the infobox, but in one the paragraph is just the word hello so we also see infobox in first view. Bit confused that I'm missing something.

But yes there are certain conditions where the paragraph will not be hoisted, but this should not ever be happening on the Barack Obama page (unless it gets vandalised). T170006 relates to an edge case that does not impact the Obama page.

@Jdlrobson This test is running against Beta, not production. "Hello" is currently the first paragraph of the Obama page on beta:

ahh thanks for the explanation @Imarlier ! That explains a lot!