Page MenuHomePhabricator

[wmf.11-regression] Saved filters titles are not displayed in Active Filter area
Closed, ResolvedPublic

Description

  1. Login as a user who has saved filters previously to wmf.11 deployment.
  2. On RC page click to load one of the saved filters - the filter will load, but not titles will be displayed. The filter can be saved again. (the bookmark icon is active).

Renaming one of the old filters does not make the name of the filters displayed.

  1. If you save again one of the saved filters, there will be two undistinguishable instances of the same filter.
  2. say, I have 'July 11 filter'
  3. I click on it and it loads without displaying a title. The bookmark icon is active and I can save it.
  4. I save 'July 11 filter' as 'July 11 saved again on Dec 05'.
  5. Now, when I click on 'July 11 filter' - 'July 11 saved again on Dec 05' will be displayed.

Note: newly saved filters behave as expected - no issues found.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 6 2017, 11:57 PM
Etonkovidova updated the task description. (Show Details)Dec 7 2017, 12:05 AM

Change 395899 had a related patch set uploaded (by Catrope; owner: Sbisson):
[mediawiki/core@wmf/1.31.0-wmf.11] RCLFilters: Make 'target' and 'to/from' sticky

https://gerrit.wikimedia.org/r/395899

Change 395899 merged by jenkins-bot:
[mediawiki/core@wmf/1.31.0-wmf.11] RCLFilters: Make 'target' and 'to/from' sticky

https://gerrit.wikimedia.org/r/395899

Mentioned in SAL (#wikimedia-operations) [2017-12-07T03:00:14Z] <catrope@tin> Synchronized php-1.31.0-wmf.11/resources/src/mediawiki.rcfilters/: T182268 (duration: 00m 57s)

Checked in enwiki (wmf.11) - the issue is fixed.

Etonkovidova closed this task as Resolved.Dec 8 2017, 12:13 AM