Page MenuHomePhabricator

Silently replace “OOjs UI” with “OOUI” in non-disruptive manner
Closed, ResolvedPublic

Description

Bringing clarity and simplification to contributors and volunteer users of our library is the premise here.
We're already mixing OOjs UI and OOUI, sometimes even wrongly OOjs when OOUI is meant in the documentation.
Let's unify it non-disruptive in all relevant places to OOUI.
Starting point:

Event Timeline

Volker_E created this task.Dec 7 2017, 10:12 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 7 2017, 10:12 PM
Volker_E updated the task description. (Show Details)Dec 7 2017, 10:23 PM
Volker_E added a subscriber: Quiddity.
Prtksxna updated the task description. (Show Details)Dec 11 2017, 1:35 PM
Volker_E updated the task description. (Show Details)Jan 10 2018, 2:05 AM

@Quiddity helped gladly with MW redirects. Thanks!

Volker_E updated the task description. (Show Details)Jan 11 2018, 10:26 PM
Volker_E updated the task description. (Show Details)
Volker_E updated the task description. (Show Details)Jan 11 2018, 10:34 PM

Change 403836 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[oojs/ui@master] docs: Replace “OOjs UI” with “OOUI” in code comments

https://gerrit.wikimedia.org/r/403836

Change 403836 merged by jenkins-bot:
[oojs/ui@master] docs: Use “OOUI” as unified name in code comments

https://gerrit.wikimedia.org/r/403836

Change 403972 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[oojs/ui@master] build, demos, docs: Use “OOUI” as unified name

https://gerrit.wikimedia.org/r/403972

Change 403972 merged by jenkins-bot:
[oojs/ui@master] build, demos, docs: Use “OOUI” as unified name

https://gerrit.wikimedia.org/r/403972

Volker_E updated the task description. (Show Details)Jan 12 2018, 9:45 PM

From here on the remaining instances of “OOjs UI” are far more disruptive to replace and we should weigh in, how much of this makes sense from case to case:
OOUI itself:

  • DraggableElement.js dataTransfer.setData( 'application-x/OOjs-UI-draggable', this.getIndex() );

Gerrit/Git:

& GitHub mirrror?

All things code:

  • MW core
  • Flow
  • Echo
  • Kartographer
  • MMV
  • MobileFrontend
  • RevSlider

All things mediawiki.org:

  • Fine to replace step-by-step

Inner structure:

  • CSS classes; we'll probably never be able to replace them if not v2.0.0 of OOUI

From here on the remaining instances of “OOjs UI” are far more disruptive to replace and we should weigh in, how much of this makes sense from case to case:
OOUI itself:

  • DraggableElement.js dataTransfer.setData( 'application-x/OOjs-UI-draggable', this.getIndex() );

Inner structure:

  • CSS classes; we'll probably never be able to replace them if not v2.0.0 of OOUI

1.0.0 maybe? Would be a weird way to welcome 1 though 🤔

Volker_E triaged this task as Normal priority.Jan 17 2018, 1:03 AM
Volker_E updated the task description. (Show Details)

Change 404630 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/Echo@master] Use “OOUI” as unified name for code comments

https://gerrit.wikimedia.org/r/404630

Change 404631 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/Flow@master] Use “OOUI” as unified name in docs & code comments

https://gerrit.wikimedia.org/r/404631

Change 404632 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/MobileFrontend@master] Use “OOUI” as unified name for code comments

https://gerrit.wikimedia.org/r/404632

Change 404630 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Use “OOUI” as unified name for code comments

https://gerrit.wikimedia.org/r/404630

Change 404633 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/ContentTranslation@master] Use “OOUI” as unified name for code comments

https://gerrit.wikimedia.org/r/404633

Change 404632 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Use “OOUI” as unified name for code comments

https://gerrit.wikimedia.org/r/404632

Change 404634 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/MultimediaViewer@master] Use “OOUI” as unified name in code comments

https://gerrit.wikimedia.org/r/404634

Change 404633 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Use “OOUI” as unified name for code comments

https://gerrit.wikimedia.org/r/404633

Change 404634 merged by jenkins-bot:
[mediawiki/extensions/MultimediaViewer@master] Use “OOUI” as unified name in code comments

https://gerrit.wikimedia.org/r/404634

Change 404631 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Use “OOUI” as unified name in docs & code comments

https://gerrit.wikimedia.org/r/404631

Change 405238 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[integration/docroot@master] Use “OOUI” as unified name in code comments

https://gerrit.wikimedia.org/r/405238

Volker_E updated the task description. (Show Details)Jan 19 2018, 2:26 AM

Change 405238 merged by jenkins-bot:
[integration/docroot@master] Use “OOUI” as unified name

https://gerrit.wikimedia.org/r/405238

Volker_E updated the task description. (Show Details)
Volker_E updated the task description. (Show Details)Jan 25 2018, 10:17 PM
Volker_E updated the task description. (Show Details)Jan 30 2018, 4:52 PM

Change 407201 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/core@master] Hygiene: Use “OOUI” as unified name in build and code documentation

https://gerrit.wikimedia.org/r/407201

Change 407203 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/Kartographer@master] Use “OOUI” as unified name in docs & code comments

https://gerrit.wikimedia.org/r/407203

Change 407204 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/RevisionSlider@master] Hygiene: Use “OOUI” as unified name in code comments

https://gerrit.wikimedia.org/r/407204

Change 407205 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/UploadWizard@master] Use “OOUI” as unified name in docs & code comments

https://gerrit.wikimedia.org/r/407205

Change 407205 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Use “OOUI” as unified name in docs & code comments

https://gerrit.wikimedia.org/r/407205

Change 407204 merged by WMDE-Fisch:
[mediawiki/extensions/RevisionSlider@master] Hygiene: Use “OOUI” as unified name in code comments

https://gerrit.wikimedia.org/r/407204

Change 407201 merged by jenkins-bot:
[mediawiki/core@master] Hygiene: Use “OOUI” as unified name in build and code documentation

https://gerrit.wikimedia.org/r/407201

Change 407203 merged by jenkins-bot:
[mediawiki/extensions/Kartographer@master] Use “OOUI” as unified name in docs & code comments

https://gerrit.wikimedia.org/r/407203

Volker_E moved this task from Backlog to Doing on the OOUI board.Feb 2 2018, 1:59 AM
Volker_E updated the task description. (Show Details)Feb 3 2018, 3:46 AM

Change 407878 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/QuickSurveys@master] Use “OOUI” as unified name in docs & code comments

https://gerrit.wikimedia.org/r/407878

Change 407879 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/CollaborationKit@master] Use “OOUI” as unified name in docs & code comments

https://gerrit.wikimedia.org/r/407879

Change 407880 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[mediawiki/extensions/CentralNotice@master] Use “OOUI” as unified name in docs & code comments

https://gerrit.wikimedia.org/r/407880

Change 407879 merged by jenkins-bot:
[mediawiki/extensions/CollaborationKit@master] Use “OOUI” as unified name in docs & code comments

https://gerrit.wikimedia.org/r/407879

Change 407878 merged by jenkins-bot:
[mediawiki/extensions/QuickSurveys@master] Use “OOUI” as unified name in docs & code comments

https://gerrit.wikimedia.org/r/407878

Change 407880 merged by jenkins-bot:
[mediawiki/extensions/CentralNotice@master] Use “OOUI” as unified name in docs & code comments

https://gerrit.wikimedia.org/r/407880

Volker_E updated the task description. (Show Details)
Volker_E updated the task description. (Show Details)
Volker_E updated the task description. (Show Details)Feb 4 2018, 3:26 AM
Volker_E updated the task description. (Show Details)

Change 408024 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[oojs/ui@master] DraggableElement: Replace OOjs-UI with OOUI for code hygiene

https://gerrit.wikimedia.org/r/408024

Change 408024 merged by jenkins-bot:
[oojs/ui@master] DraggableElement: Replace OOjs-UI with OOUI for code hygiene

https://gerrit.wikimedia.org/r/408024

Change 416902 had a related patch set uploaded (by VolkerE; owner: VolkerE):
[VisualEditor/VisualEditor@master] Hygiene: Use “OOUI” as unified name in build

https://gerrit.wikimedia.org/r/416902

Change 416902 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] build: Use “OOUI” as unified name for library upgrade script

https://gerrit.wikimedia.org/r/416902

Change 417033 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (f46b51b83)

https://gerrit.wikimedia.org/r/417033

Change 417033 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (f46b51b83)

https://gerrit.wikimedia.org/r/417033

Other places like repo names, npm or connected doc.wikimedia.org seem unfeasible from effort needed POV. Maybe keeping in mind for a v1 release.

Volker_E closed this task as Resolved.Mar 23 2018, 11:39 PM
Volker_E claimed this task.