Page MenuHomePhabricator

UploadBaseTest::testCheckXMLEncodingMissmatch failing on PHP 7.1
Closed, ResolvedPublic

Description

6 Apr 2018
1) UploadBaseTest::testCheckXMLEncodingMissmatch with data set #0 ('<?xml version="1.0" encoding=...</svg>', true)
Failed asserting that true matches expected false.
/home/travis/build/wikimedia/mediawiki/tests/phpunit/includes/upload/UploadBaseTest.php:565
/home/travis/build/wikimedia/mediawiki/tests/phpunit/MediaWikiTestCase.php:420
12) UploadBaseTest::testCheckXMLEncodingMissmatch with data set #0 ('<?xml version="1.0" encoding=...</svg>', true)

Failed asserting that true matches expected false.


/home/travis/build/wikimedia/mediawiki/tests/phpunit/includes/upload/UploadBaseTest.php:560
/home/travis/build/wikimedia/mediawiki/tests/phpunit/MediaWikiTestCase.php:416
/home/travis/build/wikimedia/mediawiki/maintenance/doMaintenance.php:94

Details

Event Timeline

Reedy created this task.Dec 7 2017, 11:04 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 7 2017, 11:04 PM
Reedy moved this task from Unsorted to PHP 7.1 on the [DO NOT USE] NewPHP board.Dec 7 2017, 11:06 PM
Krinkle reopened this task as Open.Apr 6 2018, 2:21 AM
Krinkle closed this task as a duplicate of T182380: UploadBaseTest fails on PHP 7.2.
Krinkle updated the task description. (Show Details)
Krinkle moved this task from Backlog to Core on the MW-1.31-release board.Jun 2 2018, 1:40 AM

Change 437887 had a related patch set uploaded (by Legoktm; owner: Legoktm):
[mediawiki/core@master] Fix UploadBase::checkXMLEncodingMissmatch() on PHP 7.1+

https://gerrit.wikimedia.org/r/437887

Legoktm claimed this task.Jun 7 2018, 12:59 AM

Change 437893 had a related patch set uploaded (by Krinkle; owner: Legoktm):
[mediawiki/core@REL1_31] Fix UploadBase::checkXMLEncodingMissmatch() on PHP 7.1+

https://gerrit.wikimedia.org/r/437893

Change 437893 merged by jenkins-bot:
[mediawiki/core@REL1_31] Fix UploadBase::checkXMLEncodingMissmatch() on PHP 7.1+

https://gerrit.wikimedia.org/r/437893

Change 437887 merged by jenkins-bot:
[mediawiki/core@master] Fix UploadBase::checkXMLEncodingMissmatch() on PHP 7.1+

https://gerrit.wikimedia.org/r/437887

Legoktm closed this task as Resolved.Jun 7 2018, 8:58 AM