Page MenuHomePhabricator

When switching groups of filters, search criteria sticks, but not applied
Closed, ResolvedPublic

Description

  1. Open filters menu and type some search criteria
    • Main filter group is filtered using search criteria
  2. Change filter group to Namespaces or Tags
  3. Search criteria stays the same, but all filters are displayed
    • Expected behavior would be that search criteria and search results are in sync:
      • If we keep search criteria, we would need to re-apply it on different filters group
      • If we want fresh state, we need to reset search criteria when changing filter groups

Other bugs/inconsistencies visible on gif above:

  • "No filters found" is looking differently on main filter group vs namespace group. Message on namespace group has more space at the bottom.
  • In some scenarios, "No filters found" is not displayed on namespace group

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 12 2017, 12:21 PM

@Petar.petkovic comment:

"No filters found" is looking differently on main filter group vs namespace group. Message on namespace group has more space at the bottom.

The reason of not having the consistent look might be due to the back arrow icon to navigate from Namespaces/Tags back to Filters. It's not so noticeable when search criteria return results for Filters and Tags.

No results:

When some results are returned:

I re-checked the issue - it seems to be working quite logical now (it's fixed in wmf.15 - testwiki and mediawiki).

  • In the filter search area enter e.g. "edit" - the Filters names/description containing "edit" will be displayed.
  • Switch to Namespaces filters - "edit" will become ":edit" and "No filters found" will be displayed
  • switch to Tags filters -":edit" will become "#edit" and some Tags will be displayed.

So, the filters from different groups (Namespace, Tags) will be displayed according to entered search criteria. I am closing the ticket as resolved.

Etonkovidova closed this task as Resolved.Jan 3 2018, 6:57 PM

"No filters found" is looking differently on main filter group vs namespace group. Message on namespace group has more space at the bottom.

The reason of not having the consistent look might be due to the back arrow icon to navigate from Namespaces/Tags back to Filters. It's not so noticeable when search criteria return results for Filters and Tags.

No results:

Actually, black arrow is not the reason why I said "No filters found" looks different. There is more white space on the bottom for Tags/Namespaces compared to regular filter view. You can see that clearly on two images you posted under "No results". The reason is that one parent elements has min-height, but that white space is not causing any problems, so probably not worth solving.

The other issue was that, after some weird sequence of actions, you get no filters as search results, but message "No filters found" isn't showing. You can see that on the end of gif from description.

I have checked reported issues on Mediawiki and everything works smoothly now. Thank you @Mooeypoo for dealing with this!