Page MenuHomePhabricator

Tests should have covered regression in T182936
Closed, ResolvedPublic

Description

This was quite a few large bugs rolled together, which demonstrated a large hole in our test coverage.

Write the missing tests.

Details

Related Gerrit Patches:
mediawiki/extensions/ORES : masterIntegration tests for API

Event Timeline

awight created this task.Dec 15 2017, 1:56 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 15 2017, 1:56 AM
Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptDec 15 2017, 9:14 AM

Just a few hours before this breakage, we discussed the idea of writing a browser test that checks if the ORES filters are available on Special:RC on every production wiki that's supposed to have them. That would help with most historical cases, but not this one though; for that, @Etonkovidova proposes adding a browser test that checks that the "very likely good" filter shows more than 0 results.

As for unit tests, they did catch T182936: [wmf.12 -regression] ORES filters do not work ! But they were updated (to the wrong values) by the same commit.

Yeah, I've been thinking about how we can write proper tests for this. It's complex due to the nature of the hook, I have been thinking about writing tests that actually have to access database. One good case is the API hook handlers we have. i.e. We write more of integration test than unit test for the extension.

Change 400623 had a related patch set uploaded (by Ladsgroup; owner: Amir Sarabadani):
[mediawiki/extensions/ORES@master] Integration tests for API

https://gerrit.wikimedia.org/r/400623

Change 400623 merged by jenkins-bot:
[mediawiki/extensions/ORES@master] Integration tests for API

https://gerrit.wikimedia.org/r/400623

Halfak closed this task as Resolved.Jan 30 2018, 8:31 PM