Page MenuHomePhabricator

DateInputWidget on Special:Contributions doesn't always link to user's newer contributions (due to start= vs offset=)
Open, Needs TriagePublic

Description

Observe the page shown by this URL: https://en.wikipedia.org/w/index.php?limit=50&title=Special%3AContributions&contribs=user&target=Dbachmann&namespace=&tagfilter=&start=2016-03-10&end=2016-03-11

While I can click "older 50" to see their older contributions, there is no link for "newer 50" even though this user has many newer contributions.

Event Timeline

Wbm1058 created this task.Dec 18 2017, 4:50 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 18 2017, 4:50 AM
Aklapper closed this task as Invalid.Dec 18 2017, 9:28 AM

That is expected behavior, as you defined start=2016-03-10&end=2016-03-11. If you set limit=500 you won't have any "older" or "newer" links.

Closing task as invalid.

Wbm1058 reopened this task as Open.EditedDec 18 2017, 1:52 PM

OK, so I click the blue link for "500" and it shows me 500 edits, which extend well beyond the date range I selected. Now it does show both "newer 500" and "older 500".
https://en.wikipedia.org/w/index.php?title=Special:Contributions&offset=20160311235959&limit=500&contribs=user&target=Dbachmann&namespace=&tagfilter=&start=2016-03-10&end=2016-03-11

Furthermore now I can click "newer 500" and it shows me 500 edits between March 14–31, 2016 which is totally outside the range specified by

&start=2016-03-10&end=2016-03-11

that is still found at the end of the URL
https://en.wikipedia.org/w/index.php?title=Special:Contributions&dir=prev&offset=20160310130321&limit=500&contribs=user&target=Dbachmann&namespace=&tagfilter=&start=2016-03-10&end=2016-03-11

Maybe this is behavior that you would expect, but it is not the behavior that I would expect. Is the expected behavior documented somewhere? Where is the documentation for the special page Special:Contributions? It's not the easiest thing to find specific APIs from the https://www.mediawiki.org/wiki/API:Main_page ... Thanks.

The fundamental issue here is that start=2016-03-10 is incompatible with offset=20160311235959. You can't start from two different dates! Is start a new parameter; why was it created? It seems like a fork of offset. What are the rules for behavior when both are specified?

Aklapper renamed this task from Contributions DateInputWidget doesn't always link to a user's newer contributions to DateInputWidget on Special:Contributions doesn't always link to user's newer contributions (due to start= vs offset=).Dec 19 2017, 4:57 PM