Release OOUI v0.24.4 with some backported patches
Closed, ResolvedPublic

Description

The last release, OOUI v0.24.3, caused some annoying issues. The next release was planned to be OOUI v0.25.0 and it has a few breaking changes already merged. We should release OOUI v0.24.4 before it, with some backported patches, so that we can have the fixes for v0.24.3 deployed separately from the inevitable new breakage from v0.25.0.

Fixed for regressions in v0.24.3:

Other things that we want to release a bit sooner:

@Volker_E and @matmarex are both available to do this on Wednesday.

matmarex created this task.Dec 18 2017, 9:55 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 18 2017, 9:55 PM
Volker_E triaged this task as High priority.Dec 18 2017, 10:00 PM
matmarex added a comment.EditedDec 18 2017, 10:05 PM

I created the branch "v0.24.4", initially pointing to a48d69b22bf89b87f2f931a4c23401e6214562d4 (v0.24.3 release tag), using the interface at https://gerrit.wikimedia.org/r/#/admin/projects/oojs/ui,branches. We should be able to cherry-pick changes to it using Gerrit's "Cherry Pick" button and merge them.

@Volker_E When we've got everything in, use git checkout origin/v0.24.4 (or possibly gerrit instead of origin, depending on your local repo setup) to switch to this branch, and make the release as normal. You might need to use git push origin HEAD:refs/for/v0.24.4 to push the release tag commit, git review will probably do something dumb or refuse to work. (This syntax is described at https://www.mediawiki.org/wiki/Gerrit/Alternatives_to_git-review#Push_for_review.)

matmarex updated the task description. (Show Details)Dec 18 2017, 10:06 PM

(After making the v0.24.4 release, we should add the release notes to History.md in master, and make sure not to duplicate them in v0.25.0 release notes. We weren't very careful about this in the past, https://gerrit.wikimedia.org/r/#/c/399114/ corrects existing notes and can serve as an example.)

Change 399244 had a related patch set uploaded (by Bartosz Dziewoński; owner: Catrope):
[oojs/ui@v0.24.4] ClippableElement: Fix JS error when Floatable is mixed in but disabled

https://gerrit.wikimedia.org/r/399244

Change 399244 merged by jenkins-bot:
[oojs/ui@v0.24.4] ClippableElement: Fix JS error when Floatable is mixed in but disabled

https://gerrit.wikimedia.org/r/399244

Change 399250 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[oojs/ui@v0.24.4] DropdownWidget: Remove stray use of this.$()

https://gerrit.wikimedia.org/r/399250

Change 399250 merged by jenkins-bot:
[oojs/ui@v0.24.4] DropdownWidget: Remove stray use of this.$()

https://gerrit.wikimedia.org/r/399250

Change 399253 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[oojs/ui@v0.24.4] Introduce OO.ui.getDefaultOverlay

https://gerrit.wikimedia.org/r/399253

Change 399253 merged by jenkins-bot:
[oojs/ui@v0.24.4] Introduce OO.ui.getDefaultOverlay

https://gerrit.wikimedia.org/r/399253

Change 399254 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[oojs/ui@v0.24.4] Put menus/popups of infused PHP widgets into the default overlay

https://gerrit.wikimedia.org/r/399254

Change 399254 merged by jenkins-bot:
[oojs/ui@v0.24.4] Put menus/popups of infused PHP widgets into the default overlay

https://gerrit.wikimedia.org/r/399254

matmarex updated the task description. (Show Details)Dec 19 2017, 9:06 PM
matmarex updated the task description. (Show Details)Dec 20 2017, 6:27 PM

Change 399446 had a related patch set uploaded (by Bartosz Dziewoński; owner: Prtksxna):
[oojs/ui@v0.24.4] icons: Add 'lightbulb' icon

https://gerrit.wikimedia.org/r/399446

Change 399446 merged by jenkins-bot:
[oojs/ui@v0.24.4] icons: Add 'lightbulb' icon

https://gerrit.wikimedia.org/r/399446

Change 399448 had a related patch set uploaded (by Bartosz Dziewoński; owner: VolkerE):
[oojs/ui@v0.24.4] icons: Add 'stop' icon to Apex theme

https://gerrit.wikimedia.org/r/399448

Change 399448 merged by jenkins-bot:
[oojs/ui@v0.24.4] icons: Add 'stop' icon to Apex theme

https://gerrit.wikimedia.org/r/399448

Change 399450 had a related patch set uploaded (by Bartosz Dziewoński; owner: VolkerE):
[oojs/ui@v0.24.4] [DEPRECATING CHANGE] icons: Flag unused 'quotesAdd' & 'redirect' as to be removed

https://gerrit.wikimedia.org/r/399450

Change 399450 merged by jenkins-bot:
[oojs/ui@v0.24.4] [DEPRECATING CHANGE] icons: Flag unused 'quotesAdd' & 'redirect' as to be removed

https://gerrit.wikimedia.org/r/399450

matmarex updated the task description. (Show Details)Dec 20 2017, 7:20 PM

Change 399469 had a related patch set uploaded (by Bartosz Dziewoński; owner: VolkerE):
[oojs/ui@v0.24.4] [DEPRECATING CHANGE] icons: Flag unused 'bellOn' icon as to be removed

https://gerrit.wikimedia.org/r/399469

matmarex updated the task description. (Show Details)Dec 20 2017, 9:15 PM

Change 399469 merged by jenkins-bot:
[oojs/ui@v0.24.4] [DEPRECATING CHANGE] icons: Flag unused 'bellOn' icon as to be removed

https://gerrit.wikimedia.org/r/399469

Current status: we finished backporting and merged the release notes commit (https://gerrit.wikimedia.org/r/#/c/399476/), but we had trouble publishing the release, since apparently the build process for the PNG images only works on James' computer. (On mine, it completes successfully but all the images are blank; on Volker's it fails, T179992#3852886).

@Volker_E If you can't get it to work, we could just skip PNG optimization for this release? We don't even use them in production in MediaWiki, except the checkbox. Running grunt publish-build --force might just be enough to make it complete (just make sure they don't disappear or something).

@matmarex Yeah, I could also go step by step and pull them from other release and manually add the few icons. But that's not what automated build step is intended for…

matmarex added a comment.EditedDec 21 2017, 12:38 AM

We could also remove that dumb step for good.

matmarex closed this task as Resolved.Jan 2 2018, 7:48 PM
matmarex removed a project: Patch-For-Review.
matmarex added a subscriber: Jdforrester-WMF.

@Jdforrester-WMF built and published the release.