Page MenuHomePhabricator

Secondary links broken in Echo in Monobook (possibly a MenuOptionWidget regression in Apex?)
Closed, ResolvedPublic

Description

Secondary links in Echo are now broken in monobook:

This doesn't happen in Vector, and it still happens regardless of the popup being in or out of an overlay (see https://gerrit.wikimedia.org/r/#/c/399536/ that moves the popup to an overlay outside the <li>)

I suspect there's an issue with MenuOptionWidget's design in Apex.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript

@Volker_E I played around with trying to fix it, but all the adjustments don't make much sense (making the icon display:inline-block; but then reducing margin and re-aligning the label... pit of despair, that approach)

Can you take a look? We are overriding a couple of OOUI definitions, but they're only with the icon size so they shouldn't affect anything like this. Also, these are affecting Vector (MediawikiUI) without breaking this behavior.

Mooeypoo renamed this task from Secondary links broken in Echo (possibly a MenuOptionWidget regression in Apex?) to Secondary links broken in Echo in Monobook (possibly a MenuOptionWidget regression in Apex?).Dec 20 2017, 11:51 PM

@Mooeypoo I will look into this in the next couple of days…

matmarex claimed this task.Dec 27 2017, 1:39 PM
matmarex added a subscriber: matmarex.

There is a position: absolute defined for .mw-echo-ui-menuItemWidget-icon which is not being applied, because OOUI styles are more specific.

Change 400404 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/Echo@master] mw.echo.ui.MenuItemWidget: Override OOUI styles harder

https://gerrit.wikimedia.org/r/400404

Mooeypoo added a comment.EditedDec 27 2017, 7:44 PM

@matmarex awesome, thank you -- is this relatively new? The previous stylesheet already tried to override "specific" rules, it seems at some point the rules became even more specific...? (Sorry, I misread the old/new code, but I'm still curious about when this broke, if you have an idea?)

Change 400404 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] mw.echo.ui.MenuItemWidget: Override OOUI styles harder

https://gerrit.wikimedia.org/r/400404

The issue seems to be fixed - checked in betalabs:

compare with the present enwiki (wmf.12)

Etonkovidova closed this task as Resolved.Dec 29 2017, 1:24 AM