Page MenuHomePhabricator

Notifications badge icon overlaps with other links
Closed, ResolvedPublic

Description

When I access
https://pt.wikipedia.org/wiki/Special:Preferences?useskin=vector
(or https://pt.wikipedia.org/wiki/Special:Preferences?useskin=monobook)
using Firefox 58.0.1 (64-bit) on Ubuntu 17.10, the badge overlaps with the "Talk" link at the top of the page.
For example, this is what I see using the Vector skin (and pt as the user language):

Event Timeline

He7d3r created this task.Dec 22 2017, 11:00 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
SBisson added a subscriber: SBisson.Feb 1 2018, 5:30 PM

@He7d3r I could not reproduce it locally. Could you provide the following details:

  • skin
  • browser
  • custom css
  • site (which wiki)

thanks!

He7d3r updated the task description. (Show Details)Feb 2 2018, 10:10 AM
Etonkovidova added a comment.EditedFeb 9 2018, 1:41 AM

Thanks @He7d3r for adding the details.

@SBisson - strangely, the issue is not present in betalabs (Portugese, FF58) if it's a real count:

But it's easily can be seen in betalabs or ptwiki (wmf.17, Chrome) with changing data-counter-textto 99+

<a href="/wiki/Special:Notifications" class="mw-echo-notifications-badge mw-echo-notification-badge-nojs" data-counter-num="4" data-counter-text="99+" title="Your notices">Notices (4)</a>



I do not have many notifications in production, so I cannot confirm the case when the real count is 99+.

Change 422434 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/extensions/Echo@master] Add extra margin for the badge when count is 99+

https://gerrit.wikimedia.org/r/422434

Change 422434 merged by jenkins-bot:
[mediawiki/extensions/Echo@master] Add extra margin for the badge when count is 99+

https://gerrit.wikimedia.org/r/422434

Etonkovidova closed this task as Resolved.Mar 28 2018, 7:40 PM

Checked in betalabs - the fix is in place:

I'll check the fix in wmf.28.

He7d3r added a comment.Apr 7 2018, 8:34 PM

This is how it looks like on ptwiki now:


Not as good as T183539#4089165, but better than it was before.

Etonkovidova reopened this task as Open.EditedApr 8 2018, 2:58 AM

Re-opening the issue - the overlapping is still happening - not as much as it was initially reported, but it's still noticeable (wmf.28 Chrome 64 on Mac):

Another one:

on zh-classical

Mooeypoo removed Mooeypoo as the assignee of this task.Jul 25 2018, 10:45 PM
Mooeypoo added a subscriber: Mooeypoo.
Restricted Application added a project: Growth-Team. · View Herald TranscriptJul 25 2018, 10:45 PM
JTannerWMF moved this task from Inbox to To Triage on the Growth-Team board.Aug 9 2018, 6:23 PM
JTannerWMF closed this task as Resolved.Aug 23 2018, 12:22 PM
JTannerWMF claimed this task.
JTannerWMF added a subscriber: JTannerWMF.

We’ve decided to leave this issue closed after all, as the behavior is relatively acceptable.