Page MenuHomePhabricator

[betalabs-ruwiki] Internal error - No model available for [goodfaith]
Closed, ResolvedPublic

Description

In ruwiki betalabs go to the Recent Changes page - the error will be displayed.

[Wj2q0wpEE4AAAEk0XTUAAAAD] /wiki/%D0%A1%D0%BB%D1%83%D0%B6%D0%B5%D0%B1%D0%BD%D0%B0%D1%8F:%D0%A1%D0%B2%D0%B5%D0%B6%D0%B8%D0%B5_%D0%BF%D1%80%D0%B0%D0%B2%D0%BA%D0%B8 InvalidArgumentException from line 42 of /srv/mediawiki/php-master/extensions/ORES/includes/Storage/SqlModelLookup.php: No model available for [goodfaith]

Backtrace:

#0 /srv/mediawiki/php-master/extensions/ORES/includes/Hooks.php(361): ORES\Storage\SqlModelLookup->getModelId(string)
#1 /srv/mediawiki/php-master/extensions/ORES/includes/Hooks/ChangesListHooksHandler.php(384): ORES\Hooks::joinWithOresTables(string, string, array, array, array)
#2 /srv/mediawiki/php-master/includes/Hooks.php(177): ORES\Hooks\ChangesListHooksHandler::onChangesListSpecialPageQuery(string, array, array, array, array, array, FormOptions)
#3 /srv/mediawiki/php-master/includes/Hooks.php(205): Hooks::callHook(string, array, array, NULL)
#4 /srv/mediawiki/php-master/includes/specialpage/ChangesListSpecialPage.php(1482): Hooks::run(string, array)
#5 /srv/mediawiki/php-master/includes/specials/SpecialRecentchanges.php(375): ChangesListSpecialPage->runMainQueryHook(array, array, array, array, array, FormOptions)
#6 /srv/mediawiki/php-master/includes/specials/SpecialRecentchanges.php(326): SpecialRecentChanges->runMainQueryHook(array, array, array, array, array, FormOptions)
#7 /srv/mediawiki/php-master/includes/specialpage/ChangesListSpecialPage.php(862): SpecialRecentChanges->doMainQuery(array, array, array, array, array, FormOptions)
#8 /srv/mediawiki/php-master/includes/specialpage/ChangesListSpecialPage.php(560): ChangesListSpecialPage->getRows()
#9 /srv/mediawiki/php-master/includes/specials/SpecialRecentchanges.php(168): ChangesListSpecialPage->execute(NULL)
#10 /srv/mediawiki/php-master/includes/specialpage/SpecialPage.php(522): SpecialRecentChanges->execute(NULL)
#11 /srv/mediawiki/php-master/includes/specialpage/SpecialPageFactory.php(578): SpecialPage->run(NULL)
#12 /srv/mediawiki/php-master/includes/MediaWiki.php(287): SpecialPageFactory::executePath(Title, RequestContext)
#13 /srv/mediawiki/php-master/includes/MediaWiki.php(851): MediaWiki->performRequest()
#14 /srv/mediawiki/php-master/includes/MediaWiki.php(523): MediaWiki->main()
#15 /srv/mediawiki/php-master/index.php(43): MediaWiki->run()
#16 /srv/mediawiki/w/index.php(3): include(string)
#17 {main}

Event Timeline

Restricted Application added a project: Scoring-platform-team. · View Herald TranscriptDec 23 2017, 1:04 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Catrope added subscribers: awight, Catrope.EditedJan 9 2018, 7:31 PM

These kinds of errors should be caught and not crash the entire interface. There's another task about this but I can't find it. @awight do you remember which task it is by any chance?

The issue is not happening anymore in betalabs ruwiki (goodfatih model was enabled there) and since T181191: Make ORES-consuming pages more robust to ORES errors covers the issue, I am closing this ticket.

Etonkovidova closed this task as Resolved.Jan 15 2018, 6:43 PM