Possible bug around WikiFunctions.Parse.Parsers
Open, LowestPublic

Description

Hello
Some users at French Wikipedia have some problems to load AWB. The problem is described here, on the english wikipedia AWB bugs page , but no solution came from there : https://en.wikipedia.org/wiki/Wikipedia_talk:AutoWikiBrowser/Bugs#Possible_bug_:_WikiFunctions.Parse.Parsers

Since problably friday 15th I'm unable to launch AWB. When loading, an error message stops the process : "error come with WikiFunctions.Parse.Parsers". After this, AWB takes a long time to load, with an error of loading time... Then the software is launched, but disabled or not working.

It appears this problem might only appears with users connecting at french WIkipedia. We have no idea where this problem can come from. Any help ? could this be a bug, or only on client side ? Then, what is the problem, so we can know what to do ?
Regards. (and merry christmas!)

Archimea created this task.Dec 25 2017, 7:59 PM
Archimea updated the task description. (Show Details)Dec 25 2017, 8:02 PM
Archimea triaged this task as High priority.
Reedy added a comment.Dec 27 2017, 1:59 PM

Works fine for me on 5.9.0.0 (current latest release) and on the SVN version

I have the problem described by Archimea, and I think the problem is specific to fr.wp.

Reedy added a comment.Dec 27 2017, 2:29 PM

I tried it on frwiki

Hmmm, OK. Here is a screenshot of the error warning, if it can help.

Reedy added a comment.Dec 27 2017, 2:42 PM

There's a clue here in the "Network access error", AWB can't load something from the wiki, but it's unclear as to what it actually is

I already took a look at this pages AWB can use:
https://fr.wikipedia.org/wiki/Wikip%C3%A9dia:AutoWikiBrowser/CheckPage
https://fr.wikipedia.org/wiki/Wikip%C3%A9dia:AutoWikiBrowser/Template_redirects
https://fr.wikipedia.org/wiki/Wikip%C3%A9dia:AutoWikiBrowser/Typos
but each last edit has been done on those pages a long time ago and don't correspond to date the bug appeared.

Archimea added a comment.EditedDec 29 2017, 6:14 PM

When I click OK on the same dialog box shown by Jules78120. AWB continue to load, but slown down and stop when "Mainform : Set project ()" appears. Then a new dialog box is oppened.

Gratus added a subscriber: Gratus.Jan 4 2018, 3:26 PM

Hello, I had similar problem in the past. Please verify if you can connect to Internet with "Internet Explorer" browser. Indeed AWB seem to take IE's config. Finally, to me, it was a proxy error in IE (but was ok with others browsers).

AWB work fine to me currently.

Regards.

I can connect to Internet with my Edge browser, yes.

Archimea added a comment.EditedJan 9 2018, 12:39 PM

Someone at french wiki found a similar problem has occured in 2015. Could this one be related ? : look here.

Archimea raised the priority of this task from High to Unbreak Now!.Jan 9 2018, 12:41 PM
Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptJan 9 2018, 12:41 PM

Today, i just tried to launch AWB, and i had a log report :

"La référence d'objet n'est pas définie à une instance d'un objet."
"ullReferenceException in MainForm.SetProject"

description:

workaround:

Exception:NullReferenceException
Message:La référence d'objet n'est pas définie à une instance d'un objet.
Call stack:<pre> à AutoWikiBrowser.MainForm.SetProject(String code, ProjectEnum project, String customProject, String protocol) à AutoWikiBrowser.MainForm.LoadPrefs(UserPrefs p) à AutoWikiBrowser.MainForm.LoadPrefs() à AutoWikiBrowser.MainForm.MainForm_Load(Object sender, EventArgs e)</pre>

OS: Microsoft Windows NT 6.1.7601 Service Pack 1
version: AutoWikiBrowser (5.9.0.0), WikiFunctions (5.9.0.0), revision 12137 (2016-12-25 12:48:36)
net: 2.0.50727.8762
duplicate:
site: https://en.wikipedia.org

Hope this helps.

Archimea added a comment.EditedJan 9 2018, 11:51 PM

I've got a new information. I just logged out from Wikipedia on my web browser and launched AWB wich ran fine. I could make an edit with AWB : see here.

I logged in to .fr.ikipedia in my browser, without stopping AWB. This forced me to reconnect in AWB, but it works: I was then able to edit with AWB too.

I shut down AWB and launched AWB again and all works fine. I have to do some further testing (restart my computer), but i can't do this right now.
If someone know something : Be bold

I didn't get this log report, and what you describe (disconnect, reconnect) doesn't work for me.

It doesn't work for me either.

Archimea added a comment.EditedJan 10 2018, 10:39 AM

Hello
It's stange, this morning, i can launch AWB without problem, but I can't logg in. saddly :(

Any help ?

Archimea closed this task as Resolved.Jan 16 2018, 12:25 PM
Archimea lowered the priority of this task from Unbreak Now! to Lowest.
Archimea added a comment.EditedJan 16 2018, 12:30 PM

AS we reported on the french AWB wikipedia page (here). This problem might have been introduced by the Mediawiki update that occured mid-december 2017. The last Mediawiki update done few days ago resolved the problem for everyone.

Thank's for have not help us in anyway
;P :p
regards

Reedy added a comment.Jan 16 2018, 3:57 PM

AS we reported on the french AWB wikipedia page (here). This problem might have been introduced by the Mediawiki update that occured mid-december 2017. The last Mediawiki update done few days ago resolved the problem for everyone.

Thank's for have not help us in anyway
;P :p
regards

I can't read French. And how would we know of something you reported on a random page onwiki...?

Randomly closing reports as resolved, marking them as different priorities... Is not helpful.

Please also don't make sarcastic remarks. People do this as a volunteer effort. No one has to help you, no one is paid to help you.

And it if was an MW issue... Why isn't everyone affected? Other languages etc?

Archimea added a comment.EditedJan 16 2018, 4:19 PM

I also do edit on few wikis without payment as a volunteer effort too. Do you want me to thank you for help did not come ?
You can't read French, but neither the fews informations that i tried to add, that prevent you or someone to say the problem don't come this side.
I don't know why this problem occures only on some systems (if i knew, i would had probably never come here),, more, the problem is back. I think i t is related with the fact that the last mediawiki update has been undone this night... that let me think the problem is more to be related to Mediawiki rather than AWB... and that look for solutions here is not helpfull.
Well. I NOW ask nothing, I stop this, all this mess, It's the last time you see me here. Try with other contributors.
regards

Archimea reopened this task as Open.Jan 16 2018, 4:20 PM
Archimea removed a subscriber: Archimea.
Reedy added a subscriber: Archimea.Jan 16 2018, 4:42 PM

You can't read French, but neither the fews informations that i tried to add, that prevent you or someone to say the problem don't come

If you say so.

Works fine for me on 5.9.0.0 (current latest release) and on the SVN version

I have the problem described by Archimea, and I think the problem is specific to fr.wp.

I tried it on frwiki

Archimea added a comment.EditedJan 16 2018, 4:47 PM

Those were before the few informations i tried to give, like
<pre> à AutoWikiBrowser.MainForm.SetProject(String code, ProjectEnum project, String customProject, String protocol) à AutoWikiBrowser.MainForm.LoadPrefs(UserPrefs p) à AutoWikiBrowser.MainForm.LoadPrefs() à AutoWikiBrowser.MainForm.MainForm_Load(Object sender, EventArgs e)</pre>
or "Mainform : Set project ()" appears"... and one other, since December 29, 2017.
But i think that's not related to the problem, and probably won't fix it in anyway...
good continuation.

Archimea removed a subscriber: Archimea.Jan 16 2018, 4:50 PM

@Archimea and @Jules78120 : Is the problem still current or was it solved in the meantime?

Did you try to re-"install" and configure the software from scratch?