Page MenuHomePhabricator

Declare dependencies of Wikibase Quality extensions in extension.json
Open, Needs TriagePublic

Description

WikibaseQuality requires Wikibase, WikibaseQuality{Constraints,ExternalValidation} require WikibaseQuality. We should declare this in extension.json’s requires key (documentation).

I’d delay this until T88258: Convert WikibaseRepository, WikibaseClient, WikibaseLib and WikibaseView to use extension registration is done.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 2 2018, 4:56 PM

Note: after the archiving of WikibaseQuality (T205065) and WikibaseQualityExternalValidation (T204490), the only remaining dependency to be declared would be WikibaseQualityConstraints → Wikibase.