Page MenuHomePhabricator

Cite: Replace "getSelectedItem" with "findSelectedItem"
Closed, ResolvedPublic1 Estimated Story Points


We would like to rename some get() functions for naming consistency.

Replace instances of getSelectedItem with findSelectedItem in modules/ve-cite/ve.ui.MWReferenceSearchWidget.js in MediaWiki's Cite extension.

You are expected to provide a patch in Wikimedia Gerrit. See for how to set up Git and Gerrit.

Event Timeline

Prtksxna triaged this task as Lowest priority.Jan 3 2018, 5:55 AM
Prtksxna created this task.
Aklapper updated the task description. (Show Details)Jan 3 2018, 4:11 PM

Yes. That, and OOUI being updated in core. Once done, I was planning to accept on the GCI site but merge on Gerrit only once things are ready in core.

Ah, ok, +1! @Aklapper already imported the task :P

Change 403338 had a related patch set uploaded (by Zoranzoki21; owner: Zoranzoki21):
[mediawiki/extensions/Cite@master] Replace "getSelectedItem" with "findSelectedItem"

Kizule claimed this task.Jan 10 2018, 2:57 AM
Restricted Application added a project: User-Kizule. · View Herald TranscriptJan 10 2018, 2:57 AM
Kizule moved this task from Backlog to Doing on the OOUI board.
Jdforrester-WMF closed this task as Resolved.Jan 10 2018, 8:15 PM
Jdforrester-WMF edited projects, added Cite, VisualEditor; removed Patch-For-Review.
Jdforrester-WMF set the point value for this task to 1.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJan 10 2018, 8:15 PM

Change 403338 merged by jenkins-bot:
[mediawiki/extensions/Cite@master] Replace "getSelectedItem" with "findSelectedItem" for consistency