Page MenuHomePhabricator

Flow: Replace "getSelectedItem" with "findSelectedItem"
Closed, ResolvedPublic


We would like to rename some get() functions for naming consistency.

Replace instances of getSelectedItem with findSelectedItem in modules/editor/editors/visualeditor/ui/widgets/ in MediaWiki's Flow extension.

You are expected to provide a patch in Wikimedia Gerrit. See for how to set up Git and Gerrit.

Event Timeline

Prtksxna triaged this task as Lowest priority.Jan 3 2018, 6:02 AM
Prtksxna created this task.
Prtksxna added a project: Google-Code-in-2017.
Aklapper updated the task description. (Show Details)Jan 3 2018, 4:11 PM
Kizule claimed this task.Jan 10 2018, 10:36 AM
Kizule moved this task from Backlog to Doing on the OOUI board.
Restricted Application added a project: User-Kizule. · View Herald TranscriptJan 10 2018, 10:36 AM

Change 403386 had a related patch set uploaded (by Zoranzoki21; owner: Zoranzoki21):
[mediawiki/extensions/Flow@master] Replace "getSelectedItem" with "findSelectedItem"

Jdforrester-WMF closed this task as Resolved.Jan 10 2018, 8:13 PM
Jdforrester-WMF edited projects, added StructuredDiscussions; removed Patch-For-Review.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJan 10 2018, 8:13 PM

Change 403386 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Replace "getSelectedItem" with "findSelectedItem" for consistency