Page MenuHomePhabricator

Wikibase Travis CI PHP 5.5 build fails with segmentation fault
Closed, ResolvedPublic

Description

After merging https://gerrit.wikimedia.org/r/#/c/400685/ (later re-submitted as https://gerrit.wikimedia.org/r/#/c/401699/) PHP 5.5 (wiki language set to Russian) job of Wikibase's Travis CI build started to fail with the segmentation fault, see e.g. https://travis-ci.org/wikimedia/mediawiki-extensions-Wikibase/builds/324099938 or https://travis-ci.org/wikimedia/mediawiki-extensions-Wikibase/builds/324502805.

The failure seems suspicious as there is little indication the segmentation fault would be related to the code change. PHP 5.5 build on Jenkins (though using slightly different setting with English wiki language and mysql instead of sqlite) does not cause any of such failure.

Event Timeline

I've been trying to reproduce the failure locally using close-to-Travis setting but I get no segfaults.
Also, when running tests on Travis with PHPUnit debug flag, there is no segfaults (build is green).

Also as unrelated change seem to have taken the segfault away: https://travis-ci.org/wikimedia/mediawiki-extensions-Wikibase/builds/324634265, for it to come back soon without a clear reason: https://travis-ci.org/wikimedia/mediawiki-extensions-Wikibase/builds/324668385, I am tending to say this looks like some issue on Travis, or some PHP/PHPUnit bug.

Per the above, I'd make the failing job "non-voting" on Travis, to avoid the noise. Only temporarily, hopefully the issue gets solved soon.

Keeping the ticket empty for now, as maybe segfaults do indicate some issue in the actual Wikibase code.

I'll have an eye on the problematic job, let's see how the situation develops.

WMDE-leszek triaged this task as Normal priority.Jan 4 2018, 1:46 PM
WMDE-leszek moved this task from Backlog to In Progress on the Wikidata-Sprint-2018-01-03 board.

Change 402048 had a related patch set uploaded (by WMDE-leszek; owner: WMDE-leszek):
[mediawiki/extensions/Wikibase@master] Temporarily allow failures of Travis PHP 5.5 lang=ru job

https://gerrit.wikimedia.org/r/402048

Change 402048 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Temporarily allow failures of Travis PHP 5.5 lang=ru job

https://gerrit.wikimedia.org/r/402048

WMDE-leszek removed WMDE-leszek as the assignee of this task.Jan 4 2018, 2:56 PM
WMDE-leszek moved this task from In Progress to Done on the Wikidata-Sprint-2018-01-03 board.

Change 406983 had a related patch set uploaded (by WMDE-leszek; owner: WMDE-leszek):
[mediawiki/extensions/Wikibase@master] Make all jobs required to pass again

https://gerrit.wikimedia.org/r/406983

Change 406983 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Make all jobs required to pass again

https://gerrit.wikimedia.org/r/406983

WMDE-leszek closed this task as Resolved.Jan 31 2018, 8:34 AM
WMDE-leszek claimed this task.

The issues seem to be gone now.