[betalabs] "Uncaught TypeError: this.isFloatableOutOfView is not a function" when clicking on "Switch editor"
Closed, ResolvedPublic1 Story Points

Description

The error is displayed only in betalabs.

  1. In betalabs go to any page (or SD board) click on any editing tab - 'Edit' or 'Edit source'.
  2. Click on the pencil icon to switch to a different editor

<div class="oo-ui-widget oo-ui-widget-enabled oo-ui-toolGroup oo-ui-iconElement oo-ui-indicatorElement oo-ui-popupToolGroup oo-ui-listToolGroup" aria-disabled="false" title="Switch editor">

The "Uncaught TypeError: this.isFloatableOutOfView is not a function" will be displayed.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptThu, Jan 11, 12:12 AM
Etonkovidova renamed this task from [wmf.15-regression] "Uncaught TypeError: this.isFloatableOutOfView is not a function" when clicking on "Switch editor" to [betalabs] "Uncaught TypeError: this.isFloatableOutOfView is not a function" when clicking on "Switch editor".
Etonkovidova updated the task description. (Show Details)

Looks like PopupToolGroup doesn't mixin FloatableElement?

Change 403755 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[oojs/ui@master] PopupToolGroup: Revert "Fix popup direction changing..."

https://gerrit.wikimedia.org/r/403755

Needs backporting?

Change 403755 merged by jenkins-bot:
[oojs/ui@master] PopupToolGroup: Revert "Fix popup direction changing..."

https://gerrit.wikimedia.org/r/403755

Change 403949 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/core@master] OOUI: Manually pull in fix from I99caad7b ahead of the release cycle

https://gerrit.wikimedia.org/r/403949

Jdforrester-WMF triaged this task as Unbreak Now! priority.
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF assigned this task to matmarex.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.
Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptFri, Jan 12, 4:58 PM

Change 403949 merged by jenkins-bot:
[mediawiki/core@master] OOUI: Manually pull in fix from I99caad7b ahead of the release cycle

https://gerrit.wikimedia.org/r/403949

Etonkovidova updated the task description. (Show Details)Sat, Jan 13, 1:52 AM

Seems to be fixed - checked in betalabs.

matmarex closed this task as Resolved.Mon, Jan 15, 4:52 PM
matmarex removed a project: Patch-For-Review.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMon, Jan 15, 4:52 PM