Page MenuHomePhabricator

Add pages that use RelatedSites links to maintenance categories
Closed, ResolvedPublic2 Story Points

Description

In order to facilitate bot removal of the links, we should have the extension automatically put all articles that use such links into a maintenance category like "Category:Pages using related sites links".

Event Timeline

kaldari created this task.Jan 18 2018, 10:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 18 2018, 10:14 PM

English Wikivoyage handled this with a template+bot. They now have articles sorted into the following maintenance categories:

  • Category:Articles with Wikipedia links and none on Wikidata (430 pages)
  • Category:Articles with Wikipedia links different to Wikidata (2,215 pages)
  • Category:Articles with Commons page links different to Wikidata (91 pages)
  • Category:Articles with Commons category links different to Wikidata (291 pages)

Now we need to get the English Wikivoyage community to fix those pages/Wikidata entries, and we also need to figure out a solution for non-English projects. Hmm, this really needs some CL support.

Elitre added a subscriber: Elitre.Feb 9 2018, 1:55 PM

Now we need to get the English Wikivoyage community to fix those pages/Wikidata entries, and we also need to figure out a solution for non-English projects. Hmm, this really needs some CL support.

You can see on Office wiki how to structure such a request. TYVM!

@kaldari it's been 2 months and I haven't heard per the comment above, so I'm assuming no support is needed.

@Elitre: It still definitely needs CL support. The problem is that no one owns this bug (currently), so there's no one to shepherd it. Hopefully it will be assigned to Community Tech at some point in the near future (per the code stewardship reviews).

insert thumbs up emoji here

Change 430833 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[mediawiki/extensions/RelatedSites@master] Add pages using this ext to a tracking category

https://gerrit.wikimedia.org/r/430833

MaxSem claimed this task.May 4 2018, 1:02 AM
kaldari set the point value for this task to 2.
kaldari moved this task from Ready to In Development on the Community-Tech-Sprint board.

Change 430833 merged by jenkins-bot:
[mediawiki/extensions/RelatedSites@master] Add pages using this ext to a tracking category

https://gerrit.wikimedia.org/r/430833

MaxSem closed this task as Resolved.May 10 2018, 11:27 PM
MaxSem moved this task from In Development to Q1 2018-19 on the Community-Tech-Sprint board.