Page MenuHomePhabricator

Timeless and OOUI on Special:Search aren't friendly
Closed, ResolvedPublic

Description

I do a lot of complex searches (especially to get a response within the timeout limit), which have long search strings. On Fx 57 and a narrow-enough monitor, this search box loses the end of the text underneath the search button.

It appears to be a combination of Timeless and OOUI, as Vector displays the entirety of the string with the search box outside of the form.

Event Timeline

Izno created this task.Jan 19 2018, 3:17 AM
Izno updated the task description. (Show Details)

I was confused by this report at first, so for reference:

The highlighted green area is not supposed to overlap the button.

Looks like this is caused by input[type="search"] { box-sizing: content-box; } in Timeless' CSS overriding .oo-ui-textInputWidget input, .oo-ui-textInputWidget textarea { box-sizing: border-box; } in OOUI's CSS.

Volker_E removed a project: OOUI.Apr 9 2018, 7:16 PM
Izno added a comment.Aug 3 2018, 3:40 PM

Slightly different issue now, in addition. The search button flashes in and out--It is not present at all (except for a sliver on the right) if I hover over the form for the search string. If I hover over the x or the button itself, or if my mouse cursor anywhere else, it displays on top of the content, as described in this task.

There is some improvements on this. I do not see any issue anymore. Is it fixed?

Izno closed this task as Resolved.Mar 28 2019, 6:48 PM
Izno claimed this task.

The original report looks to have been fixed and right now my second issue looks to have been fixed.

Isarra added a subscriber: Isarra.Apr 4 2019, 9:04 PM

Looks like that also fixed several other skins.