Edit summaries containing multiple autocomments are broken
Closed, ResolvedPublic

Assigned To
Anomie
Priority
Low
Author
bzimport
Subscribers
siebrand, Anomie, He7d3r and 2 others
Projects
Tokens
"Like" token, awarded by RandomDSdevel."Like" token, awarded by He7d3r.
Reference
bz16530
Description

Author: paul.copperman

Description:
Proposed fix for regex in Linker->formatAutocomments

If an edit summary contains more than one autocomment (/* ... */), only the last one is transformed into a section link.

This behavior was introduced by r39594 , though I'm not sure if it was intended this way. In case it wasn't, I attached a quick fix for the regex in Linker->formatAutocomments. A proper solution would probably take a bit more effort. :)


Version: 1.18.x
Severity: minor
URL: http://de.wikipedia.org/w/index.php?title=Wikipedia:Auskunft&dir=prev&offset=20081130183247&limit=1&action=history

attachment autocomments.patch ignored as obsolete

bzimport added a subscriber: wikibugs-l.
bzimport set Reference to bz16530.
bzimport created this task.Via LegacyDec 2 2008, 4:29 PM
siebrand added a comment.Via ConduitJan 6 2009, 11:17 PM

+need-review

bzimport added a comment.Via ConduitMar 30 2009, 10:58 AM

paul.copperman wrote:

*** Bug 18253 has been marked as a duplicate of this bug. ***

IAlex added a comment.Via ConduitAug 2 2009, 2:50 PM
  • Bug 15481 has been marked as a duplicate of this bug. ***
bzimport added a comment.Via ConduitSep 15 2010, 1:34 AM

RSYQFIOJGWZA wrote:

It is still not working. I have a test case at http://en.wikipedia.org/w/index.php?title=Help:Edit_summary&diff=384901084&oldid=384900839

bzimport added a comment.Via ConduitSep 30 2011, 2:27 PM

sumanah wrote:

I can verify that this is still happening with MediaWiki 1.18, as shown in this test:

https://secure.wikimedia.org/wikipedia/test2/w/index.php?title=Ecology&action=historysubmit&diff=35177&oldid=7899

Paul, could you check to see whether your patch still applies cleanly against trunk, and revise/modify if necessary? Thanks!

bzimport added a comment.Via ConduitNov 24 2011, 7:28 PM

sumanah wrote:

I'm sorry for the wait, Paul. Because of the delay in reviewing your contribution, MediaWiki's codebase has changed enough that the patch no longer applies cleanly to trunk. If you revise and update the patch, and mark it with the "patch" and "need-review" keywords, we'll ensure someone reviews it a lot faster. My regrets, again. Thank you.

bzimport added a comment.Via ConduitNov 24 2011, 7:29 PM

sumanah wrote:

Comment on attachment 5552
Proposed fix for regex in Linker->formatAutocomments

Per automated testing
http://lists.wikimedia.org/pipermail/wikitech-l/2011-November/056340.html patch
no longer applies to MediaWiki trunk in Subversion.

duplicatebug added a comment.Via ConduitJan 2 2013, 11:59 AM
  • Bug 43356 has been marked as a duplicate of this bug. ***
gerritbot added a comment.Via ConduitSep 9 2014, 3:46 PM

Change 159326 had a related patch set uploaded by Anomie:
Format multiple autocomments in edit summaries

https://gerrit.wikimedia.org/r/159326

He7d3r awarded a token.Via WebNov 24 2014, 1:05 PM
gerritbot added a comment.Via ConduitDec 19 2014, 6:46 PM

Change 159326 had a related patch set uploaded (by Anomie):
Format multiple autocomments in edit summaries

https://gerrit.wikimedia.org/r/159326

Patch-For-Review

gerritbot added a comment.Via ConduitDec 30 2014, 11:38 PM

Change 159326 merged by jenkins-bot:
Format multiple autocomments in edit summaries

https://gerrit.wikimedia.org/r/159326

Anomie closed this task as "Resolved".Via WebDec 31 2014, 3:31 PM
Anomie claimed this task.

This should be deployed to WMF wikis with 1.25wmf14, see https://www.mediawiki.org/wiki/MediaWiki_1.25/Roadmap for the schedule.

RandomDSdevel awarded a token.Via WebJan 12 2015, 11:25 PM

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.