Page MenuHomePhabricator

Create translated versions of new Thank You page
Closed, ResolvedPublic

Description

Following Robin's creation of the new fundraising Thank You page in English (T179713, https://wikimediafoundation.org/wiki/Thank_You/en) we should set about converting it into a template which can be translated for other campaigns.

Checklist for putting pages live:

Event Timeline

Pcoombe created this task.Jan 19 2018, 4:58 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 19 2018, 4:58 PM

I created a multilingual TY page template and a corresponding English translation template. Here’s the TY page output that’s using {{{translatable messages}}}.

Since the 2017 redesign of the TY page uses changed/new copy, I figured to create a new translation template. Some parts of the 2014 translation template can be reused, but quite a few translations are missing. I suggest to translate the whole template again to make sure we’re not missing anything. I’m planning to have „1 template to rule them all“ (not a separate English one). It’ll make it more maintainable and easier to roll out changes in the future.

That brings up the next key point: Are we going to settle for the current TY page copy/content (Template | Output)? I think it’s worth thinking about before we’re going to translate it in multiple language and adapt all templates. What do you think, @MeganHernandez_WMF @TSkaff @jrobell @Pcoombe @spatton @CCogdill_WMF @MNoorWMF, do we leave the TY page as it is or do you think some parts could be improved? Lets start the discussion here.

... also adding @kaythaney to the discussion here! 👋

Thanks @schoenbaechler. I'm happy with working from the current content.

Also appreciating how you cunningly made all the text center aligned, so that right-to-left languages shouldn't be an issue ;)

TSkaff added a comment.Feb 5 2018, 6:46 PM

@schoenbaechler +1 template to rule them all.

schoenbaechler added a comment.EditedFeb 7 2018, 5:23 PM

As discussed in our campaigns call yesterday, I transferred all translation strings from the English TY page into a Google Spreadsheet:

https://docs.google.com/spreadsheets/d/1rM0klHRXA4bY4i-AG1DjNMgWl5uCnD-HTzUnVa10io8/edit?usp=sharing

Can you work with this format @jrobell? Let me know if I can be of any assistance with obtaining the translations.

Thanks!

schoenbaechler added a comment.EditedFeb 21 2018, 4:03 PM

Continued working on the multilingual Thank You page today. The page’s now completely designed in a modular way. It allows to easily swap primary/secondary call to actions on the page.

Furthermore, I started to create the translation templates. Aiming to get most of the work done by the end of this week. We discussed on Slack that we want to try localized sharing messages. Here’s an example:

Acabo de fer una donació a la @Viquipedia. Dóna suport al coneixement lliure! #mencantalaViquipèdia

In the course of working on the main template and in order to achieve localized sharing messages, I was wondering if it’s possible to insert {{{translatable-messages}}} into html attributes? E.g. <a href="{{{share-link}}}" or <a href="</html>{{{share-link}}}<html>"`. Haven’t been successful in doing that yet. Maybe @Pcoombe knows a solution or workaround?

Also @Pcoombe, do you know an easy way to reliably clear the cache on wmf.org pages? I made some changes to the main template of the page below but it doesn’t seem to show them: https://wikimediafoundation.org/wiki/Thank_You_2018/en

Here’s the link where the changes have an effect:
https://wikimediafoundation.org/wiki/Thank_You_2018

(e.g. the clickable Endowment title: “Ensuring the future of free knowledge: the Wikimedia Endowment.”)

Thanks for the help.

it should be possible to include messages in HTML attributes, but you need to be careful with URLs as they will get automatically turned into links by MediaWiki if they are outside of <html> tags which breaks the attributes. I ran into this when adding the survey link to the template, and fixed it by putting only the changing part of the link inside the </html>{{{variable}}}<html>

There is also a {{urlencode:}} function that might be helpful if you want to simplify the share links at all: https://www.mediawiki.org/wiki/Help:Magic_words#URL_data

Regarding the update problems, it looks like you were editing the "Thank You 2018" page rather than Template:Thank You 2018 which is the one actually used. I merged your changes to the Template page and it looks okay now.

Thanks @Pcoombe for your help and merge. ´{{{urlencode:}}`is a game changer 💪

schoenbaechler added a comment.EditedFeb 23 2018, 10:53 AM

Alright, I’ve created the Thank You pages in the following languages:

Some notes

  • I’ve added the parameter ?country=US to all links to also display translations for the store section. It makes it easier for us to check if the output and translations are correct. Please note that the store’s currently only displayed in the US.
  • Share message on Twitter is localized per country, as well as the corresponding hashtags
  • All survey links point to the current English survey on surveymonkey. It’s adaptable per country.
  • @Pcoombe: if we want to show the endowment section only in the US, it’s probably best to add it to the common.js as well to keep it consistent. Not quite sure what the status of this is, maybe @kaythaney knows more?

Next steps (@Pcoombe @jrobell @TSkaff @spatton):

  • Since this was a lot of copy pasting and manual work, I’d appreciate some QA for the pages listed above. Anyone interested in checking these? (working links, obvious display problems and so on). Merci!
  • I assume that we have to check with chapters if they’re satisfied with the page and translations are correct, right?

Of course, any feedback in general is highly appreciated 🙌.

Thanks,
Robin


CC @MeganHernandez_WMF @CCogdill_WMF @MNoorWMF

So awesome, thank you, Robin!

Okay I've looked at all these and can't see any obvious problems or missing translations.

Made a few changes to the template:

  • You should specify a "language" parameter (updated all the pages to do this)
    • The shared links will be localised for the given language
    • Pages will automatically be put in the correct language category
    • Hebrew is now correctly RTL, although we should get a speaker to check everything looks okay here
  • Share message encoding is now all handled by template, removed duplication of messages
  • Survey link is https://www.surveymonkey.com/r/DLSJWTY by default, and can override it on a per-language basis as needed (have done this for Italian)
  • Hide the Endowment section except in English for now
  • Improved links for editing when logged in (can now edit individual page, or template)
  • Changed a couple of things so that previewing and viewing diffs work better

I think we're ready to put live any of these pages where the translations have been confirmed.

Thank you very much Robin, Peter and all. I have reviewed and made some tweaks to the Swedish version. We shall just remove the endowment info, then the svSE is good to go!

Thanks for checking these @Pcoombe and your updates to the templates. Especially like how you got rid of the share message redundancy! Excited to the see the pages in action. Inspired by @jrobell , I also tweaked the German version here and there.

New Swedish and German pages are now live. Waiting on final proofreading for Italian and the rest.

And Italian is now live.

Pcoombe updated the task description. (Show Details)Mar 16 2018, 4:54 PM
Restricted Application added subscribers: jeblad, jhsoby. · View Herald TranscriptMar 16 2018, 4:54 PM
Pcoombe closed this task as Resolved.Jul 16 2018, 7:43 PM
Pcoombe claimed this task.

Much delayed, but I finished putting all of these live as part of T189664: Move fundraising thank you pages to donate.wikimedia.org! Full list can be found at https://donate.wikimedia.org/wiki/Category:Thank_You_page