Page MenuHomePhabricator

Wikistats 2: New Pages split by editor type wrongly claims no anonymous users create pages
Closed, ResolvedPublic

Description

Though the current configuration of enwiki prevents logged-out users from creating pages, this wasn't originally the case, and still isn't on some wikis.

However, if on https://stats.wikimedia.org/v2/#/en.wikipedia.org/contributing/new-pages you go to the "split by editor type" and "all time", it reports '0' for anonymous users for every month from January 2001.

Counter-example: Oxen on enwiki was created in May 2003 by 209.150.193.201:
https://en.wikipedia.org/w/index.php?title=Oxen&action=info

(Sadly some very old edits are lost to time and aren't represented in our databases, and so those pages like Goat will be potentially miscounted as they're created by "Conversion script" https://en.wikipedia.org/w/index.php?title=Goat&action=info, but for those that aren't it'd be nice to have this correct.)

Event Timeline

Jdforrester-WMF triaged this task as Low priority.Jan 19 2018, 7:37 PM
Jdforrester-WMF created this task.
Restricted Application added a project: Analytics. · View Herald TranscriptJan 19 2018, 7:37 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Nuria edited projects, added Analytics-Kanban; removed Analytics.Jan 22 2018, 4:49 PM
fdans edited projects, added Analytics; removed Analytics-Kanban.Mar 22 2018, 4:55 PM
fdans raised the priority of this task from Low to Normal.Mar 26 2018, 4:45 PM
fdans moved this task from Incoming to Data Quality on the Analytics board.

ping @JAllemandou this issue might be significant for "total article count"

@Milimetric, @JAllemandou
(grosking)
Do we know what is the cause of this issue, after the recent quality work?

Yes, there is a patch to fix this in the base data: https://gerrit.wikimedia.org/r/c/analytics/refinery/source/+/491494
Not sure when this will get deployed, and some more checks are needed on wikistats to ensure the change is visible.

mforns raised the priority of this task from Normal to Needs Triage.Mar 25 2019, 5:31 PM
mforns triaged this task as Normal priority.
Nuria added a comment.May 14 2019, 8:40 PM

Fixed with 2019-04 snapshot, closing. Thanks for reporting.

Nuria closed this task as Resolved.May 14 2019, 8:43 PM