Page MenuHomePhabricator

Wikimedia dumps should contain FlaggedRevs data, including article status
Closed, ResolvedPublic

Description

Author: Wiki.Melancholie

Description:
Wikimedia dumps do not contain any information about the (flagged) article status.

The XML dumps should contain tags to include the sighting/reviewing status of page revisions.

This is very important for offline usage or mirroring of wiki data (to only use flagged/reviewed revisions)!


Version: unspecified
Severity: enhancement
URL: http://download.wikimedia.org/backup-index.html

Details

Reference
bz16546

Event Timeline

bzimport raised the priority of this task from to Lowest.Nov 21 2014, 10:27 PM
bzimport set Reference to bz16546.

Wiki.Melancholie wrote:

If possible, consider to also include given flag comments like it's done for edit summaries ("revision tagging").

Aaron, did you push any forward on this? If you cant get to it let know and I'll move it along.

(In reply to comment #2)

Aaron, did you push any forward on this? If you cant get to it let know and
I'll move it along.

Seems like part of the work seems in place with http://www.mediawiki.org/wiki/Special:Code/MediaWiki/47947 .
Do we just need to add it to the main worker thread?

aaron added a comment.May 29 2009, 9:46 PM

That code creates stable-only dumps, but doesn't have the extra meta data.

aaron added a comment.May 30 2009, 5:03 AM

(In reply to comment #3)

(In reply to comment #2)

Aaron, did you push any forward on this? If you cant get to it let know and
I'll move it along.

Seems like part of the work seems in place with
http://www.mediawiki.org/wiki/Special:Code/MediaWiki/47947 .
Do we just need to add it to the main worker thread?

Perhaps you are thinking of bug 17189 :)

jayvdb added a comment.Oct 8 2012, 4:07 AM
  • Bug 35975 has been marked as a duplicate of this bug. ***
jayvdb added a comment.Oct 8 2012, 4:09 AM

Assigning to bug to Ariel, per bug 35975 comment 1.

Meno25 removed a subscriber: Meno25.Aug 28 2016, 8:15 AM