Page MenuHomePhabricator

Measure time spent by Thumbor connecting to and reading from Swift
Closed, ResolvedPublic

Description

If I'm reading the python-swiftclient code correctly, there's no timeout on get_object. As surfaced by the Varnish slow log, this means that Thumbor sometimes spends a lot of time on that operation (and possibly writing to Swift as well, but that part doesn't slow down responses to clients).

Measuring that duration and reporting it in the response headers would allow us to verify whether or not 60+ seconds 200 responses from Thumbor are caused by Swift or something else in the thumbnailing stack.

Event Timeline

Gilles triaged this task as Normal priority.Jan 22 2018, 12:24 PM
Gilles created this task.
Gilles renamed this task from Measure time spent by Thumbor reading from Swift to Measure time spent by Thumbor connecting to and reading from Swift.Jan 22 2018, 12:40 PM
Gilles moved this task from Inbox to Doing on the Performance-Team board.Jan 30 2018, 9:02 PM

Change 407412 had a related patch set uploaded (by Gilles; owner: Gilles):
[operations/debs/python-thumbor-wikimedia@master] Upgrade to 1.11

https://gerrit.wikimedia.org/r/407412

Change 407412 merged by Filippo Giunchedi:
[operations/debs/python-thumbor-wikimedia@master] Upgrade to 1.11

https://gerrit.wikimedia.org/r/407412

Gilles closed this task as Resolved.Feb 2 2018, 10:57 AM