Page MenuHomePhabricator

Send out call for membership renewal
Closed, ResolvedPublic8 Story Points

Description

Once T186211: Open membership login in Zynatic is ready and any blockers in T186213: Ensure payment and Fortnox integration is working in Zynatic are done we want to actually send out a call for old members to renew their memberships. This should be done from within Zynatic and may possibly be combined with the account creations in T186211: Open membership login in Zynatic.

The call should include:

Related Objects

Event Timeline

Lokal_Profil updated the task description. (Show Details)Feb 12 2018, 8:10 AM
Jopparn renamed this task from Send out membership renewal call to Send out call for membership renewal.Mar 12 2018, 11:14 AM
Jopparn updated the task description. (Show Details)
Jopparn added a project: User-SaraMortsell.
Jopparn moved this task from Backlog to This week on the User-SaraMortsell board.
Jopparn set the point value for this task to 8.Mar 12 2018, 11:26 AM
Lokal_Profil added a comment.EditedMar 15 2018, 3:58 PM

The order in which these are sent out is:

  • Welcome message - reference upcoming e-mail with login details
  • Mass generate accounts
  • Invoice

@SaraMortsell @Jopparn

Everything is ready in Zynatic now. But I'm not sure if we tested mass generating accounts, and if it was successful.

Mass generating accounts tested. Emails go out containing username and password (no link to login though). Logging in with these works and instantly shows you the consent pop-up.

We'll need to add a short sentence about the fact that the invoice is coming (for anyone not wanting to renew via Paypal).

The task description mentions a reminder about Wikipedia Day and the General Assembly. Don't think we've added that to the text.

Lokal_Profil added a comment.EditedMar 21 2018, 11:31 AM

The task description mentions a reminder about Wikipedia Day and the General Assembly. Don't think we've added that to the text.

This will be postponed. Plan is to have to such reminders. One for paid members and one for unpaid members (telling them they need to renew membership to be allowed to attend). That message will be sent out earlier in the same week as the General Assembly.
@SaraMortsell / @Evelina-Bang-WMSE This needs to be broken out into a new task. I'll leave that to you since it could be split into two parts (create text, send texts).

We'll need to add a short sentence about the fact that the invoice is coming (for anyone not wanting to renew via Paypal).

My suggestion (inserted before the <16 section)

Swedish:
Det går redan nu att förnya ditt medlemskap för 2018 från din medlemssida via Paypal. Det kommer att komma ett separat utskick med en faktura som kan användas för den som hellre betalar via Swish eller bankgiro.
English:
You may already renew your membership for 2018 from your membership page using Paypal. There will be a separate mailing with an invoice which can be used if you prefer paying using Swish or Bankgiro.

Your suggestion is great.

To simplify matters we'll postpone sending these to the organisations (as the welcome message needs to be tweaked somewhat). These are also not crucial from a General Assembly pov. Broken out as T190292: Send out call for membership renewal - Organisations

Lokal_Profil updated the task description. (Show Details)Mar 21 2018, 2:51 PM

When the last break-out task has been created it should be linked to from the description and then this task can be closed!

Feedback from member:

Lite att tänka på i utskicksprogramvaran. å,ä,ö fel i rubriken.
https://www.dropbox.com/s/lo08n8ngzucbrnw/Sk%C3%A4rmklipp%202018-03-21%2015.56.35.png?dl=0

Feedback from member:

Lite att tänka på i utskicksprogramvaran. å,ä,ö fel i rubriken.
https://www.dropbox.com/s/lo08n8ngzucbrnw/Sk%C3%A4rmklipp%202018-03-21%2015.56.35.png?dl=0

Weird. It looks fine in Gmail. My guess is that non utf8 software (windows) has issues with it. Will report upstream

Feedback from member:

Lite att tänka på i utskicksprogramvaran. å,ä,ö fel i rubriken.
https://www.dropbox.com/s/lo08n8ngzucbrnw/Sk%C3%A4rmklipp%202018-03-21%2015.56.35.png?dl=0

Weird. It looks fine in Gmail. My guess is that non utf8 software (windows) has issues with it. Will report upstream

Reported to Zynatic.

Also reported the i becomes l issue (and confirmed that it also holds for Niklas.

When the last break-out task has been created it should be linked to from the description and then this task can be closed!

I broke this out as T191384: send a reminder about the Wikipedia Day and General Assembly. Note that this is not the same as the one being sent out today and that this one needs text which has not yet been created.

Feedback from member:

Lite att tänka på i utskicksprogramvaran. å,ä,ö fel i rubriken.
https://www.dropbox.com/s/lo08n8ngzucbrnw/Sk%C3%A4rmklipp%202018-03-21%2015.56.35.png?dl=0

Weird. It looks fine in Gmail. My guess is that non utf8 software (windows) has issues with it. Will report upstream

Would you mind either answering this user or sending me the ticket id and I'll answer? The short answer is that subjectline encoding of åäö is not standardised and unfortunately (s)he happens to use a client which does not follow the most prevailing way of doing this.

Feedback from member:

Lite att tänka på i utskicksprogramvaran. å,ä,ö fel i rubriken.
https://www.dropbox.com/s/lo08n8ngzucbrnw/Sk%C3%A4rmklipp%202018-03-21%2015.56.35.png?dl=0

Weird. It looks fine in Gmail. My guess is that non utf8 software (windows) has issues with it. Will report upstream

Reported to Zynatic.
Also reported the i becomes l issue (and confirmed that it also holds for Niklas.

Would you mind answering this one (and the u->c one) thanking them for making us aware of the issue and offering to change their usernames if they wish.

Lokal_Profil updated the task description. (Show Details)Apr 4 2018, 7:33 AM
Lokal_Profil closed this task as Resolved.Apr 10 2018, 7:23 AM
Lokal_Profil claimed this task.

Feedback from member:

Lite att tänka på i utskicksprogramvaran. å,ä,ö fel i rubriken.
https://www.dropbox.com/s/lo08n8ngzucbrnw/Sk%C3%A4rmklipp%202018-03-21%2015.56.35.png?dl=0

Weird. It looks fine in Gmail. My guess is that non utf8 software (windows) has issues with it. Will report upstream

Reported to Zynatic.
Also reported the i becomes l issue (and confirmed that it also holds for Niklas.

Would you mind answering this one (and the u->c one) thanking them for making us aware of the issue and offering to change their usernames if they wish.

I broke this out as T191873: Rename users

Jopparn moved this task from This week to Done on the User-SaraMortsell board.Aug 6 2018, 1:58 PM