Page MenuHomePhabricator

[Bug][Regression] Tapping "Refresh location" in Nearby goes to search
Closed, ResolvedPublic

Description

Steps to reproduce

  1. Visit https://en.m.wikipedia.org/wiki/Special:Nearby
  2. Tap the "refresh location" button

Expected results

Results are updated using the user's current geolocation.

Actual results

An empty search page is shown (https://en.m.wikipedia.org/w/index.php?search=).

Environments observed

Browser Version:

  • Chromium v63.0.3239.132 (Official Build) Built on Ubuntu , running on Ubuntu 17.10 (64-bit)

OS Version:

  • Ubuntu v17.10 64b

Device Model:

  • Desktop

Device Language:

  • English

Testing criteria

Details

Related Gerrit Patches:
mediawiki/extensions/MobileFrontend : masterFix refresh button on Special:Nearby page

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 1 2018, 3:27 PM
Jdlrobson renamed this task from [Bug] Tapping "Refresh location" in Nearby goes to search to [Bug][Regression] Tapping "Refresh location" in Nearby goes to search.Feb 1 2018, 6:19 PM
Jdlrobson moved this task from Incoming to Triaged but Future on the Readers-Web-Backlog board.
Jdlrobson added subscribers: ovasileva, Jdlrobson.

Oops. @ovasileva high or normal priority?

D3r1ck01 claimed this task.Feb 1 2018, 6:45 PM
D3r1ck01 triaged this task as High priority.
D3r1ck01 awarded a token.
D3r1ck01 added a project: MobileFrontend.
D3r1ck01 added a subscriber: D3r1ck01.

Change 407477 had a related patch set uploaded (by D3r1ck01; owner: Alangi Derick):
[mediawiki/extensions/MobileFrontend@master] Fix refresh button on Special:Nearby page

https://gerrit.wikimedia.org/r/407477

D3r1ck01 added a comment.EditedFeb 1 2018, 6:47 PM

@Jdlrobson, I remember we worked on a similar issue sometime ago? How come it has resurfaced? :) I've just checked and this is it, https://gerrit.wikimedia.org/r/#/c/372869/. But it's similar :)

D3r1ck01 moved this task from Backlog to Tracking on the GeoData board.Feb 1 2018, 8:36 PM
D3r1ck01 moved this task from Backlog to Bugs on the MobileFrontend board.

@Jdlrobson, the main issue for adding some css was to remove this effect on the button on-click;


Note the blue shadow around the button? But if this is not needed, I can remove it. Thanks :)

Oops. @ovasileva high or normal priority?

High works.

Jdlrobson reassigned this task from D3r1ck01 to Nirzar.Feb 1 2018, 10:29 PM
Jdlrobson added subscribers: Volker_E, Nirzar.

The main issue of the submitting search has been fixed by a volunteer.
@Volker_E and @Nirzar can you take a look and maybe open a follow up if we need to change anything with regards to the blue shadow per https://phabricator.wikimedia.org/T186225#3939176 ? Thanks!

@Jdlrobson If I understand correctly, the refresh button pointed at the wrong action. This is fixed now.
Having a focus feedback is an essential from accessibility perspective. Why is the focus outline seen as problematic?

blue shadow is the focus ring, we need it. not problematic from design POV

Thanks all. Looks like some follow up might be needed anyhow.

@Jdlrobson, following @matmarex's comment on Gerrit, I've updated the patch to use <button type='button'>...</button> which also solves the issue of the blue shadow around the button when clicked. But the only issue now is Jenkins is reporting a failing build but this doesn't relate to the patch AFAIK. Any ideas?

Jdlrobson reassigned this task from Nirzar to D3r1ck01.Feb 5 2018, 6:09 PM

Jenkins is now happy with the patch all of a sudden :) No need to worry again, @matmarex can confirm this!

Change 407477 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Fix refresh button on Special:Nearby page

https://gerrit.wikimedia.org/r/407477

Jdlrobson reassigned this task from D3r1ck01 to ABorbaWMF.Feb 5 2018, 7:35 PM
Jdlrobson updated the task description. (Show Details)

Over to you @ABorbaWMF - this will go out on the train tomorrow.

matmarex removed a subscriber: matmarex.Feb 5 2018, 8:53 PM

Sorry for the delay. I thought the train had not yet arrived because I was getting no results at all on nearby on Beta, but then realized there are no articles tagged with Alameda. This is working now on production.

ovasileva added a subscriber: ABorbaWMF.
ovasileva closed this task as Resolved.Feb 15 2018, 6:24 PM

all done!