Page MenuHomePhabricator

Cassandra 3.11.0 incompatible with OpenJDK >= 1.8.0_162
Closed, ResolvedPublic

Description

TL;DR Were an upgrade of OpenJDK to become necessary, versions of Cassandra >= 3.6 would not start (currently pertains to RESTBase production clusters only).

As reported in CASSANDRA-14173: Cassandra utilizes classes marked private/internal in the JDK that have been removed in OpenJDK 1.8.0_162. This has been fixed and will be released as part of 3.11.2 (RSN).

See also: T178905: Upgrade RESTBase cluster to Cassandra release: 3.11.2

Event Timeline

Eevans created this task.Feb 2 2018, 9:04 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 2 2018, 9:04 PM
mobrovac edited subscribers, added: fgiunchedi; removed: Aklapper.
Eevans closed this task as Resolved.Jun 11 2018, 3:26 PM
Eevans claimed this task.

The RESTBase Cassandra cluster has been upgraded to 3.11.2; Resolving