Page MenuHomePhabricator

PHP Fatal Error: Class undefined: MediaWikiServices - ThanksHooks
Closed, ResolvedPublic

Description

https://en.wikipedia.beta.wmflabs.org/w/index.php?title=Selenium_Echo_link_test_0.7791232640420875&action=history gives a 503

Logstash says:

[9021d8ae] PHP Fatal Error: Class undefined: MediaWikiServices

MediaWiki or an installed extension requires this class but it is not embedded directly in MediaWiki's git repository and must be installed separately by the end user.

/srv/mediawiki/php-master/extensions/Thanks/includes/ThanksHooks.php

Line 104

https://logstash-beta.wmflabs.org/app/kibana#/doc/logstash-*/logstash-2018.02.06/mediawiki?id=AWFsCmrCf_wiEkeAuq66&_g=()

Event Timeline

Addshore created this task.Feb 6 2018, 4:59 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptFeb 6 2018, 4:59 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Jdlrobson triaged this task as Unbreak Now! priority.Feb 6 2018, 5:00 PM

Seems to be impacting quite a few key pages on mobile and desktop - diffs and history not viewable.

Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptFeb 6 2018, 5:00 PM

Change 408556 had a related patch set uploaded (by Addshore; owner: Addshore):
[mediawiki/extensions/Thanks@master] Import MediaWikiServices in ThanksHooks

https://gerrit.wikimedia.org/r/408556

Addshore claimed this task.Feb 6 2018, 5:01 PM
Restricted Application added a project: User-Addshore. · View Herald TranscriptFeb 6 2018, 5:01 PM
Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptFeb 6 2018, 5:03 PM
matmarex reopened this task as Open.Feb 6 2018, 5:12 PM
matmarex added subscribers: Tgr, Dzahn, Paladox and 3 others.

Change 408556 merged by jenkins-bot:
[mediawiki/extensions/Thanks@master] Import MediaWikiServices in ThanksHooks

https://gerrit.wikimedia.org/r/408556

matmarex added a comment.EditedFeb 6 2018, 5:15 PM

This was reported three times before it reached production:

How should issues like this (unexplained 500/503) be reported so that they are investigated?

Addshore added a comment.EditedFeb 6 2018, 5:17 PM

How should issues like this (unexplained 500/503) be reported so that they are investigated?

I guess with Beta-Cluster-reproducible, which should probably be checked at branch / train deploy time for group0 for new / high prio stuff.

I also made this ticket a blocker of the train, as stuff was evidently quite broken.

Addshore closed this task as Resolved.Feb 6 2018, 5:17 PM

Test link in desc works now

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptFeb 6 2018, 5:17 PM

Good question. I suspect these all should have been tagged unbreak now on creation. That would have helped as it would have got a wider audience attention.

Tgr added a comment.Feb 6 2018, 6:38 PM

How should issues like this (unexplained 500/503) be reported so that they are investigated?

I guess with Beta-Cluster-reproducible, which should probably be checked at branch / train deploy time for group0 for new / high prio stuff.

T186186: History broken on beta when logged in was filed last Wednesday, with Beta-Cluster-reproducible. Should I have added it as a train blocker then? In hindsight probably would have been a good idea, but that does not bring the ticket to the relevant team's attention. Should there be some process/expectation to triage beta cluster bugs for a team's repos more quickly?

I suspect these all should have been tagged unbreak now on creation.

An error that will only reach production in a week is not really drop-everything-right-now-and-start-working-on-it priority though (which is how we typically use unbreak now).

An error that will only reach production in a week is not really drop-everything-right-now-and-start-working-on-it priority though (which is how we typically use unbreak now).

I'd argue it is for exactly the reason this happened but I get your point. The good things about unbreak nows is we can also downgrade them if we realise they are not a train blocker.

Should there be some process/expectation to triage beta cluster bugs for a team's repos more quickly?

Maybe, but I guess that would require help from RelEng where the problematic extension is not known. Eg. had Thanks been identified as the problem, it would have probably been routed to the right team quicker.

Tgr added a comment.Feb 6 2018, 6:59 PM

The report was tagged with Thanks (the error message made that pretty obvious) so it was the routing part that failed.