Page MenuHomePhabricator

As an Explore user, I want to be able to control the content I see on that feed
Closed, ResolvedPublic

Description

Why are we doing this?

The Android app has seen a large amount of engagement with their feed customization settings. We would like to be able to extend these capabilities to iOS users. Additionally, from user testing and OTRS we often see reports of users wanting to be able to turn off a specific card type that doesn't interest them or remove a card from their feed that is upsetting for them to look at. As the Explore feed is intended to aid users in Exploring Wikipedia, it seems natural to allow users to have controls over what is presented in their feed.

Proposed solution

  • Content customization by type during on boarding
  • Ability remove cards and types of cards from feed
  • Settings for adding/removing types of cards
  • Multi-lingual user stories
  • Special story if user doesn't want any feed content: "as a search focused user I don't want the app recommending content to me, I want to be able to search quickly and effectively when opening the app"

Flows

Flow details

  • Users can customize their feed via overflow menus on each card in the Explore feed
  • Users can customize their feed via the settings screen
  • Users can customize their feed preferences by language

Proposed Designs

Explore feed w/ overflow menuAction sheetSingle card hiddenCard type hidden from action sheetSettings tabSettings screen (1 language)Settings screen (multiple languages)Settings for selected card
Zeplin: https://zpl.io/2jlj1RWZeplin: https://zpl.io/25gZn9oZeplin: https://zpl.io/VDDG5dwZeplin: https://zpl.io/2954BEeZeplin: https://zpl.io/aBOjWoeZeplin: https://zpl.io/bW1BdvKZeplin: https://zpl.io/2y7Ne8yZeplin: https://zpl.io/brrD6Yr

Example user scenarios

Scenario 1: User turns off all of the cards in their feed

User uses the overflow menu to turn off each card type in their feed
After selecting to turn off the last card type an alert is shown telling the users that by hiding this last card type they will be turning off the Explore feed
User chooses to turn off last card type

Expected behavior: Explore feed is turned off and replaced with a Settings tab, the app now opens to the Search tab

Scenario 2: User turns off all of the cards in one language and then does so in all of their other languages

Pre-requisite: User has two languages turned on (French and English)

In the Explore feed or in the Settings screen, the user turns off all of their French Explore feed cards
Now only English cards are shown in the feed
In the Explore feed or the Settings screen, the user turns off all of their English Explore feed cards
User is shown an alert that turning off all of their cards will result in turning off the Explore feed
User turns off all cards

Expected behavior: Explore feed is turned off and replaced with a Settings tab, the app now opens to the Search tab

Scenario 3: User who manually turned off all Explore feed cards adds a new language

Pre-requisite: User followed the steps outlined in Scenario 2

User adds 'Spanish' to their languages

Expected behavior: Explore feed remains set to off, users can flip the Explore feed back on to see cards in their feed or flip the
'Hide all Spanish cards from the feed' toggle to show Spanish cards only in their Explore feed

Scenario 4: User turns off all but one card type

Pre-requisite: User has turned off / hidden all but one card type in their feed

Expected behavior: The remaining card type is shown in the feed at the same regularity as it would appear on other feeds. If the user has not triggered ever triggered an event that would cause that card type to appear in the feed (eg. has not read an article yet) the feed will appear blank.

Scenario 5: User turns off Global cards

Pre-requisite: User has 2+ languages turned on

Expected behavior: Because you read, Continue reading and Picture of the day will no longer appear in the user's feed and these cards will be toggled to 'off' in Settings.

Scenario 6: User turns off all languages but not Global cards

Pre-requisite: User has 2+ search languages (eg. English and Spanish), but has turned off English and Spanish in their Feed Customization settings.

Expected behavior: Because 'Global cards' has not been toggled off, the user will still see Because you read, Continue reading and Picture of the day in their feed.

Event Timeline

JMinor created this task.Feb 6 2018, 5:45 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 6 2018, 5:45 PM
JMinor updated the task description. (Show Details)Feb 6 2018, 5:46 PM
cmadeo updated the task description. (Show Details)Feb 9 2018, 6:16 PM
cmadeo updated the task description. (Show Details)Feb 12 2018, 11:02 PM
cmadeo removed cmadeo as the assignee of this task.Feb 12 2018, 11:59 PM
cmadeo updated the task description. (Show Details)
JMinor triaged this task as Medium priority.Feb 13 2018, 9:06 PM

Question: show main page instead of setting screen - Same explore header / can put announcements there - Web view?

Hiding all of a card type - show a stack of cards behind the hidden card.

cmadeo updated the task description. (Show Details)May 14 2018, 9:56 PM
JMinor raised the priority of this task from Medium to High.May 29 2018, 9:08 PM
JoeWalsh added a subscriber: JoeWalsh.
cmadeo updated the task description. (Show Details)Jun 27 2018, 9:47 PM

After selecting to turn off the last card type an alert is shown telling the users that by hiding this last card type they will be turning off the Explore feed

@cmadeo what copy do you want for the alert? 😁

cmadeo added a comment.Jul 3 2018, 8:06 PM

@NHarateh_WMF hehe! Good catch.

Let's do:

TitleBodyRed link text
Turn off the Explore feed?Hiding all Explore feed cards will turn off the Explore tab and replace it with a Settings tabTurn off Explore feed

@NHarateh_WMF This is so awesome! Thank you!

Just one tweak:

  • When a user switches the Explore tab off from the Settings screen, can we have the 'Turn off Explore' link appear in red in the alert?
ABorbaWMF moved this task from Backlog to Ready on the Product-QA board.Jul 24 2018, 7:41 PM
ABorbaWMF added a subscriber: ABorbaWMF.

Tested across a few builds, including 6.0.0 (1463)

ABorbaWMF moved this task from Ready to Done on the Product-QA board.Aug 7 2018, 4:43 PM
JMinor closed this task as Resolved.Aug 8 2018, 7:56 PM
JMinor awarded a token.