Page MenuHomePhabricator

[LOW] Swipe to delete on first item on a date in History should not swipe away date
Closed, ResolvedPublic2 Estimate Story Points

Description

Steps to reproduce

  1. Open history
  2. Swipe to delete the first article below a date subheading

Expected

Only the list item is swiped off

Actual

Date subheading is included in the swipe action, and then reappears after swipe off

Occurring on

Wikipedia v2.7.224-alpha-2018-02-06 on Nexus (6.0.1)

Event Timeline

RHo created this task.Feb 7 2018, 9:37 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 7 2018, 9:37 PM

Expected behaviour: date is part of each item, so it gets deleted with the item it's associated with.

Estimate is for changing this behaviour so there is an item for the date as well, which can remain visible.

Charlotte renamed this task from [BUG][LOW] Swipe to delete on first item on a date in History should not swipe away date to [LOW] Swipe to delete on first item on a date in History should not swipe away date.Feb 14 2018, 6:17 PM
Charlotte edited projects, added Android-app-feature-UX-Debt; removed Android-app-Bugs.
Charlotte set the point value for this task to 2.
RHo added a subscriber: Dbrant.Feb 15 2018, 3:31 PM

hi @Charlotte @Dbrant - should the date not be a subheading element that is unconnected with the list items? It looks like part of the same bug with Multiple selection in History which was fixed on T185536:

Before:
After

Yes, that's how it should be. In RecyclerView terminology, the date should be a different type of item in the list; a type that is neither selectable or swipeable.

RHo added a comment.Feb 15 2018, 4:03 PM

In that case can we move this to [BUG] or tech debt?

RHo triaged this task as Medium priority.Mar 6 2018, 4:02 PM
RHo removed a project: Android-app-feature-UX-Debt.

Hi @schoenbaechler

Would it be better if it uses the same header view style as other lists? Here's the implementation:

In "Wikipedia langauges"

In "Add a langauge"

Hi @cooltey, a very good suggestion. Let’s go with that label style. Would it solve the swiping issue, described in the task’s description as well?

On another note, using accent50 is the wrong color choice for that label, as it’s used for links and CTA’s. Can we de-emphasize it and change its color to color_group_30 / material_theme_secondary_color in the course of this task?

Thanks!

@schoenbaechler

Would it solve the swiping issue, described in the task’s description as well?

Yes :)

On another note, using accent50 is the wrong color choice for that label, as it’s used for links and CTA’s. Can we de-emphasize it and change its color to color_group_30 / material_theme_secondary_color in the course of this task?

No problem

As we discussed, I've changed it globally.

Dbrant closed this task as Resolved.Dec 9 2019, 5:22 PM