Page MenuHomePhabricator

Show margins around the main content in the translation editor
Closed, ResolvedPublic

Description

The translation editor shows their main content (source and translated documents) with only margin in one of the sides (next to the tools sidebar). Adding margin to the other side will help to emphasise the main content as proposed in T186873.

Current stateIntended state

Notice in the comparison above how the intended state has:

  • Grey areas in both sides, using Base80 (#eaecf0).
  • Box shadow is used around the main piece of content. The box-shadow style used is the same as the one used for cards (T158410).

Event Timeline

Pginer-WMF triaged this task as High priority.Feb 12 2018, 7:33 AM
Pginer-WMF lowered the priority of this task from High to Low.Feb 16 2018, 9:41 AM

Change 412651 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] Refactor the translation view column layout to match new design

https://gerrit.wikimedia.org/r/412651

Change 412651 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Refactor the translation view column layout to match new design

https://gerrit.wikimedia.org/r/412651

Mockup of intended state shows personal header having more indentation than margins around the main content. I have made header edges and main content edges aligned. This is approximate look after the patch:


@Pginer-WMF, any thoughts?

@Pginer-WMF, any thoughts?

Ignore that aspect of the mockup (it was reusing the header component from somewhere else and was not further adjusted), your screenshot looks good in that regard.

Etonkovidova closed this task as Resolved.EditedFeb 27 2018, 7:52 PM
Etonkovidova added a subscriber: Etonkovidova.

Checked in cx2-testing - the margins have been added (disregard errors displayed in the screenshots below).

@Petar.petkovic - the task has CX2 tag and cx-testing does not have the fix. Any reason for not having the new stuff there? Is it going to be deployed (there is no deployment tag)?

cx2-testing margins are present cx-testing - no margins

@Petar.petkovic - the task has CX2 tag and cx-testing does not have the fix. Any reason for not having the new stuff there? Is it going to be deployed (there is no deployment tag)?

All the changes in the near future (this and next quarter) are focused on CX2. New changes would ideally not affect (and don't bring regressions to) CX1, since we stopped developing CX1 in favor of moving faster with CX2 development.
Given that, I suggest that onward you check specs from the ticket in CX2 and regularly check CX1 for regressions.

That can be daunting task, so we will be cautious not to bring regressions to CX1.

Once CX2 is fully functional and in usable state, it will coexist with CX1 in production. At some point, we will prohibit any new translation to be created with CX1 and give one year for translations in progress to be completed. After that, CX1 will be sunset. King will be dead. All will hail the new king - CX2 :)