CentralLogin adds new accounts without any reason
Closed, ResolvedPublic

Description

Hello. It started 25 hours ago. A lot of users have new CentralLogin wiki accounts added without any reason. I have 34 new accounts, most of them 13 hours ago. Thank you.


Most likely caused by cleanupUsersWithNoId.php autocreating users whose edits got imported into those wikis (which is what it was supposed to do). See T181731 for details.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 10 2018, 11:44 PM

Hi, please follow https://mediawiki.org/wiki/How_to_report_a_bug and always provide steps to reproduce. Where exactly (full link) do you see that you have 34 new accounts? I'm looking at https://meta.wikimedia.org/wiki/Special:CentralAuth/Khitron which is very likely not what you mean.

@Aklapper You appear to have mistyped his username. This seems related to T186945.

Hi, please follow https://mediawiki.org/wiki/How_to_report_a_bug and always provide steps to reproduce. Where exactly (full link) do you see that you have 34 new accounts? I'm looking at https://meta.wikimedia.org/wiki/Special:CentralAuth/Khitron which is very likely not what you mean.

Hello Aklapper, there is no way to REPRODUCE this bug. This is the link: https://meta.wikimedia.org/wiki/Special:CentralAuth/IKhitron.

@Aklapper You appear to have mistyped his username. This seems related to T186945.

Hi Mahir, you're right, it's Aklapper's typo. It indeed seems related. The bug I filed can be a cause for problems in T186945.

Ah, thanks a lot for the clarifications!

Tgr added a subscriber: Tgr.EditedFeb 11 2018, 2:27 AM

There have been a lot of complaints recently about people getting notifications from welcome bots on random wikis, e.g.:

This could be the root cause of that, although in that case it would have starter way sooner (the first complaints were in December).

OTOH, "25 hours ago" (ie. Friday ~11 PM UTC) corresponds reasonably well with the deployment of wmf.20 to group1/group2 (6-7 PM UTC).

Tgr added a subscriber: Anomie.Feb 11 2018, 2:31 AM

From the timing these accounts seem to be created by some sort of maintenance script, possibly T181731: Run maintenance/cleanupUsersWithNoId.php on all wikis (@Anomie any thoughts?)

Tgr added a comment.Feb 11 2018, 2:36 AM

T186945: Message welcome bots at local wikis trigger due to edits at Wikidata assumes that the cause is the wikidata edits which are propagated to recent changes of other wikis via sitelinks. In IKhitron's case the account creations do not seem to correlate with his Wikidata edits, though.

IKhitron added a comment.EditedFeb 11 2018, 11:52 AM

T186945: Message welcome bots at local wikis trigger due to edits at Wikidata assumes that the cause is the wikidata edits which are propagated to recent changes of other wikis via sitelinks. In IKhitron's case the account creations do not seem to correlate with his Wikidata edits, though.

Actually, Tgr, it can't be correlated to any Wiki site edit, because I was sleeping at that hour.

From the timing these accounts seem to be created by some sort of maintenance script, possibly T181731: Run maintenance/cleanupUsersWithNoId.php on all wikis (@Anomie any thoughts?)

The second run for T181731 (to clean up after T183019) began at 2018-02-09T20:07:55Z and went through the wikis in alphabetical order by wikiid.

No further runs of that maintenance script are planned at this time. If another bug like T183019 turns up, I'll try to remember to get future runs into Tech News or something like that.

Tgr closed this task as Resolved.Feb 13 2018, 12:13 AM
Tgr claimed this task.

The second run for T181731 (to clean up after T183019) began at 2018-02-09T20:07:55Z and went through the wikis in alphabetical order by wikiid.

Yeah that matches account creations happen in how https://meta.wikimedia.org/wiki/Special:CentralAuth/IKhitron.

I suppose autocreating the user is the expected behavior here (as opposed to just interwiki-linking them)? In that case no point in keeping this open. Someone can file a separate task about welcome bots / the welcome extension not reacting to account autocreations with 0 edits, if they feel strongly about that.

Tgr updated the task description. (Show Details)Feb 13 2018, 12:15 AM
Tgr added a comment.Feb 13 2018, 12:17 AM

Although if this happened due to imported edits, shouldn't he have more than zero edits on those wikis?

I still do not understand, @Tgr. Could you tell me, please why exactly these wikis are in my account list now, nevermind when were they added? Thank you.

Tgr reopened this task as Open.Feb 13 2018, 1:31 AM

Yeah I guess I do not understand either. The script was supposed to add local accounts for local edits which were attributed to you (created via cross-wiki import) to make it sure that history entries always point to an existing user, but it's not clear that that's what actually happened.

Recentchanges entries added to the local wiki for changes Wikidata. Perhaps I could have used different options to link them instead of creating the SUL accounts, but it's in the past now.

IKhitron added a comment.EditedFeb 13 2018, 2:08 AM

Do you mean, @Anomie, that every edit I make on some Wikidata item adds me to all wikis that have a page connected to this item? In a month all users will have 902 wiki accounts.

Anomie added a comment.EditedFeb 13 2018, 2:12 AM

It looks like the actual Wikibase code doesn't create local SUL accounts where they don't exist, but I might be wrong.

Tgr added a comment.Feb 13 2018, 2:24 AM

Per T183019#3892960 they do not create local users. But I guess they did before that bug was fixed, and the script had to handle those rows?

As I said, I could have used different options when running the script to better match Wikibase's behavior. But unless someone has a time machine they can use to tell me that last week, there's nothing we can do about it now.

Tgr closed this task as Resolved.Feb 13 2018, 3:24 AM

I wasn't complaining, just trying to understand what exactly happened. It seems like those user creations are accounted for, so we can consider this resolved.

Teles added a subscriber: Teles.Feb 22 2018, 3:15 PM