No indication to a user that only one Thank action is allowed
Closed, ResolvedPublic

Description

When I try to make two subsequent thanks to different users from page history, second thank fails, while showing as succeeded.
Here is the test from testwiki:

Two thanks, one of which is false.

Update for steps:

  1. In betalabs go to any of View history page and thank several users or the same user for several edits. The label 'thank' will change to 'thanked'.
  2. Refresh the page - all 'thanked' except the one will be gone. Special:Log will display only one thank action.
  3. Try to repeat the first step - the second 'thank' action cannot be done - 'Thank' label won't be clickable (although the 'Thank' label looks available and there is no indication that such action cannot be performed)

The Thank element is this one:

<a class="mw-thanks-thank-link jquery-confirmable-button jquery-confirmable-button-yes" href="https://en.wikipedia.beta.wmflabs.org/wiki/Special:Thanks/372164" title="Send the thank you notification" data-revision-id="372164" data-recipient-gender="unknown">Thank</a>

There should be explicit signaling to a user that the limit for 'thank' actions has been reached.

Vort created this task.Feb 11 2018, 5:10 PM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptFeb 11 2018, 5:10 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

It looks like a deliberate feature - I tested it in betalabs and testwiki. You cannot 'thank' more than one user (the label changed to 'thanked' but changes back to 'Thank' after the page refreshing.). I will clarify whether it's a configuration or a genuine bug.

Even if it's a deliberate restriction on the amount of 'Thank' from one user, users should be informed that they have reached the limit.

Etonkovidova renamed this task from Second thank fails to No indication to a user that only one Thank action is allowed.Feb 16 2018, 7:46 PM
Etonkovidova updated the task description. (Show Details)

Confirmed with @Catrope - only one 'thank' is allowed. Since there is no indication to a user that the action is limited, the issue is still valid. I've updated the bug description and moved it to Collab-Team-Triage workboard for this quarter.

This is getting more complicated, though, something is seriously weird here.

Signed in as Mooeypoo on Hebrew Wikipedia, I tried to thank MSchottlender-WMF (my staff account) and, later, @Etonkovidova's user. In both times, I see the "Thank" link being replaced by a "Thanked" confirmation message (no link) even after multiple refreshes, on the correct diff that I thanked.
However, the logs show no record of my Thank for either case.

The fact the label changed to "Thanked" suggests somewhere the system knows this thank action happened but it wasn't logged?

This doesn't seem to be "failing silently" it seems to be discriminating on what logs to display? It's very confusing.

Update: It works now when I thank another user.

Previous thank actions seemed to have been *partially* performed. I got notified as the thanker but the thankee did not see a notification, nor an email, nor was it recorded in logs.

Etonkovidova closed this task as Resolved.Feb 21 2018, 8:06 PM
Etonkovidova claimed this task.

The issue was filed for testwiki, so after the fix for T187757: Thanks thanking the wrong edit was deployed, I re-checked testwiki.

It works as follows:

  • as soon as the limit is reached (for testwiki it seems to be 12), the label Thank won't change to thanked
  • the popup appears informing a user that the limit has been reached (the wording can be improved though):

  • Special:Log for Thanks correctly records all Thanks actions
  • users who were thanked receive Thank notifications correctly.

There *might* be some issues on specific wikis, but based on the above testing, the Thanks functionality seem to be working properly.