Page MenuHomePhabricator

Maps: Remove Wikidata info from attribution overlay
Closed, ResolvedPublic

Description

The current Wikidata attribution is a long (sometimes very long) list of item IDs.

E.g. from https://en.wikivoyage.org/wiki/Prague :

regular viewon mouse hover

It's hard to see how this is useful for anyone. It also ends up getting heavily truncated so you don't even see all this even in the expanded view.

If anything, these should use the item label (e.g. "Old Town", instead of Q748211) to at least be readable. However, that would still be a very long list.

Wikidata items and properties are public domain (CC0), so there is no requirement to include prominent (or any) attribution.

A reasonable middle ground might be something like:

"Wikimedia maps | Map data © OpenStreetMap contributors | Also includes Wikidata data"

Optionally, if you click Wikidata, it could provide a more detailed list of the data used (if actually relevant).

Details

Related Gerrit Patches:
mediawiki/extensions/Kartographer : masterRemove Wikidata list of attributions
mapdata : masterRemove wikidata attributes
mediawiki/extensions/Kartographer : masterRemove extra attribution as unnecessary

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 14 2018, 7:59 AM
Yurik updated the task description. (Show Details)Feb 14 2018, 8:30 AM
TheDJ awarded a token.Feb 22 2018, 1:37 PM

We think this should just be removed completely, since there is no requirement to attribute.

kaldari added a subscriber: kaldari.Mar 6 2018, 7:25 PM

Yeah, I think just removing the Wikidata info would be best. There's already a lot of attribution info competing for space.

MaxSem added a subscriber: MaxSem.Mar 6 2018, 7:27 PM

Whatever you decided to do, please run it past Legal just like the current attribution was run.

Yurik added a subscriber: Yurik.Mar 7 2018, 5:50 PM

I think the links to Wikidata should remain, but need to be restyled. The reason these links were placed there is to allow users to view the source of the data, not to satisfy a legal requirement. One option would be to restrict the links to just the first few - this will help when the map has only a few items, but won't clutter it.

kaldari added a comment.EditedMar 7 2018, 5:58 PM

I don't think this is the right UI for showing the data source of every item in the map. Ideally that information should be associated with the items themselves, for example, when you click on a pin and it shows you the place information, it could include the Wikidata link there (either as a text link or an icon). Trying to overlay all that information on the map itself just doesn't work, IMO. It's also not especially helpful. How would I even know which Wikidata item I want to edit?

Yurik added a comment.Mar 9 2018, 3:07 AM

@kaldari I agree that when we have this many data points, they become bad. This was initially designed when you have just a few wikidata objects, e.g. the outline of a single country or the shape of some famous street. This allows users to quickly navigate to the Wikidata item in question, similar to how French Wikipedia has "edit" link next to each item in the infobox that gets generated from Wikidata.

I'm moving this to the Design column for @Pginer-WMF to have a look at. Pau, please provide a solution.

I'm moving this to the Design column for @Pginer-WMF to have a look at. Pau, please provide a solution.

I think there are two separate purposes (attribution and exploring the information), that is better to properly support them in their right place.

For the attribution area (the scope of this ticket), I think we can try to keep it minimal. That area is styled in a way that it induces people to skip it unless they really want to look for technical aspects about the map. I'd remove Wikidata mentions there in the same way that we don't show Commons watermarks over images.

To better support exploring information, improving the layers panel seems a better place to spend our efforts. There it makes sense to replace Q-IDs by the proper names those items represent and link back to Wikidata. Having a layers panel where you can easily understand what is represented in the map, select the groups you want to see (without having to look-up Q-IDs), and being able to find further info, seems a better way to support this discovery process to me.

In T187291#4060894, @Pginer-WMF wrote:

To better support exploring information, improving the layers panel seems a better place to spend our efforts. There it makes sense to replace Q-IDs by the proper names those items represent and link back to Wikidata. Having a layers panel where you can easily understand what is represented in the map, select the groups you want to see (without having to look-up Q-IDs), and being able to find further info, seems a better way to support this discovery process to me.

As someone who's found the layers panel quite confusing, I like that idea a lot Pau. I can't guarantee we'll get to it as part of this engagement (in fact, it's unlikely), but do you want to make a new ticket and include a rough sketch of what you have in mind, just to record your thoughts?

Yurik added a comment.Mar 19 2018, 8:00 PM

I agree, it would be great to have a separate "source data" UI separate from copyrights. While this UI is not there, I think we should simply set a maximum of how many WD items are shown (e.g. at most 3, plus add an ellipses if needed) - this will quickly address the problem without sacrificing the useful feature others rely on.

While this UI is not there, I think we should simply set a maximum of how many WD items are shown (e.g. at most 3, plus add an ellipses if needed)

The problem is we don't have room for even one Wikidata item. As soon as you start adding Wikidata items to that overlay, it wraps the attribution statement. Plus it seems like it might be confusing to show some Wikidata items used in the map and not others. Honestly, I don't really understand why showing the Wikidata items in the reader interface is needed at all. The Wikidata items are listed in the Wikitext. Any editor who wants to edit the map is going to look there. I agree it might be a nice-to-have feature, but it doesn't seem strictly necessary for now.

In T187291#4062626, @kaldari wrote:

While this UI is not there, I think we should simply set a maximum of how many WD items are shown (e.g. at most 3, plus add an ellipses if needed)

... Honestly, I don't really understand why showing the Wikidata items in the reader interface is needed at all.

I agree. I think those who need to know will figure it out through other means (looking at code, I guess). And for everyone else, it's just mysterious.

Yurik added a comment.Mar 19 2018, 9:13 PM

I disagree - I find sourcing data extremely useful, but either of these are hearsay. I agree that we should first and foremost honor the licensing requirement - so the easiest solution is to actually show copyright info first, followed by wikidata links. This will solve the immediate need, and we can work on a proper solution without removing otherwise perfectly useful feature.

The interface should be optimized for readers, not editors. Showing readers a list of Q codes doesn't help their understanding, especially if they are not associated with anything in particular on the map. I imagine it just looks like random garbage to someone who isn't familiar with Wikidata.

As someone who's found the layers panel quite confusing, I like that idea a lot Pau. I can't guarantee we'll get to it as part of this engagement (in fact, it's unlikely), but do you want to make a new ticket and include a rough sketch of what you have in mind, just to record your thoughts?

I created a specific ticket: T190679: Make the layers panel useful for readers to explore the map content

There are still aspects to define, but I think it captures the general idea as a starting point in case we decide to work more in this area.

I didn't realize that the Q codes are also listed in the layers panel. In that case, there is definitely no reason to list them in the attribution overlay as well. Let's remove them from the attribution overlay and improve the layers panel as Pau suggests.

kaldari renamed this task from Maps: Attribution of Wikidata is over-prominent and unreadable to Maps: Remove Wikidata info from attribution overlay.Apr 4 2018, 1:11 AM

Looking at the code, we're also gathering attribution for "page" which are images from commons. I can't find an example live for this, so I'm going off what I see in code, and it's done exactly the same as the wikidata collection -- do we want to take those off too, or just the Wikidata links?

Change 423918 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/extensions/Kartographer@master] Remove Wikidata list of attributions

https://gerrit.wikimedia.org/r/423918

The above commit removes wikidata only, and leaves image attribution; if we want to remove the image attribution too, we could fix the commit or followup.

Change 424648 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/extensions/Kartographer@master] Remove extra attribution as unnecessary

https://gerrit.wikimedia.org/r/424648

Change 424648 abandoned by Mooeypoo:
Remove extra attribution as unnecessary

Reason:
We do need commons attributions; abandoned

https://gerrit.wikimedia.org/r/424648

Change 425732 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mapdata@master] Remove wikidata attributes

https://gerrit.wikimedia.org/r/425732

Change 425732 merged by jenkins-bot:
[mapdata@master] Remove wikidata attributes

https://gerrit.wikimedia.org/r/425732

Change 423918 merged by jenkins-bot:
[mediawiki/extensions/Kartographer@master] Remove Wikidata list of attributions

https://gerrit.wikimedia.org/r/423918

Etonkovidova closed this task as Resolved.Apr 24 2018, 9:19 PM
Etonkovidova added a subscriber: Etonkovidova.

Checked - https://en.wikivoyage.org/wiki/Prague (wmf.30) - the mouse hover will not display lengthy entries for Wikidata. The layers in full-map view - https://en.wikivoyage.org/wiki/Prague#/map/0 - have those entries displayed.