Page MenuHomePhabricator

Verify latest version of flamegraph.pl locally and submit bug report if needed
Closed, ResolvedPublic

Description

There haven't been many changes, but since we occasionally get a minor error that may've been fixed upstream, let's try updating first.

Event Timeline

Krinkle triaged this task as Medium priority.Feb 14 2018, 10:51 PM
Krinkle created this task.
Gilles claimed this task.Apr 13 2018, 10:56 AM

Managed to reproduce the issue locally:

Generating /srv/xenon/svgs/daily/2018-02-13.all.reversed.svgz...
Use of uninitialized value $stack in pattern match (m//) at /usr/local/bin/flamegraph.pl line 499, <> line 100553.
Use of uninitialized value $stack in split at /usr/local/bin/flamegraph.pl line 504, <> line 100553.
Use of uninitialized value $samples in concatenation (.) or string at /usr/local/bin/flamegraph.pl line 504, <> line 100553.
Ignored 1 lines with invalid format

The latest version of flamegraph.pl doesn't fix the issue

Gilles renamed this task from Update flamegraph.pl to latest upstream version to Verify latest version of flamegraph.pl locally and submit bug report if needed.Apr 13 2018, 2:03 PM
Gilles updated the task description. (Show Details)
Gilles closed this task as Resolved.Apr 13 2018, 8:09 PM

I think I've found the cause, it's not flamegraph.pl

I'll continue the conversation on the parent task.