Page MenuHomePhabricator

Refactor the translation view column layout to match new design
Closed, ResolvedPublic

Description

In old design, we had 3 column concept - 3 equal columns for source, translation and tools. But in new design @Pginer-WMF proposed connecting the the publishing, saving controls close to the source, translation columns. That means, in new design, we have 2 columns. The first column has 2 column wide header, then source and translation columns. The second column is tools column.

This is the new design

This is illustrated below:

So, in CX2, we should re-arrange the DOM to match the new design instead of relying on CSS styling to achieve new design. I propose to leave CX1 as it is now.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 15 2018, 11:27 AM

From the diagram, it may be ambiguous what is refered as "Header". The "Header" represented here is the element with the "All translations" and publish buttons. Note that on top of it there is another element that still goes across the whole screen with the page title, notifications and the user menu (which is restyled in T186874).

Pginer-WMF lowered the priority of this task from High to Normal.Feb 16 2018, 9:40 AM
santhosh claimed this task.Feb 19 2018, 5:21 AM
santhosh moved this task from Priority backlog to In Progress on the Language-2018-Jan-Mar board.

Change 412651 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] Refactor the translation view column layout to match new design

https://gerrit.wikimedia.org/r/412651

Change 412651 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Refactor the translation view column layout to match new design

https://gerrit.wikimedia.org/r/412651

Due to error POST http://cxserver2.wmflabs.org/v2/translate/en/es/Apertium 500 (Internal Server Error), the tools columns does not get displayed. But the overall implementation looks according to the mockup.

There are minor discrepancies in cx2-testing comparing to cx-testing - they are not related to the scope of this ticket. So, @Petar.petkovic and @Pginer-WMF please review them and disregard them or let me know if some separate ticket(s) should be filed.

cx2- testing discrepanciescx-testing

There are minor discrepancies in cx2-testing comparing to cx-testing - they are not related to the scope of this ticket. So, @Petar.petkovic and @Pginer-WMF please review them and disregard them or let me know if some separate ticket(s) should be filed.

We've clearly missed a step in communicating with you how we're gonna proceed with the changes in the near future. We'll move fast and break things.

In doing so, there are currently some pieces of work that aren't documented and need follow up patches to re-implement some lost features (like gear icon). I have warned a team this could happen and will raise the concern again.

Try to stick to ticket specifics. Smaller polishing will be done later. I expect @Pginer-WMF to revisit UI elements such as that translation header you reported issues for, and that will be all polished. CX2 is not yet usable and fixing that is high priority.

Some more explanations about our team's work going forward at T186876#4008711.

Etonkovidova closed this task as Resolved.Mar 2 2018, 12:35 AM

Thanks! As long as the issues are known, it's ok for me too. The specs are implemented - the design of two column is in place and no regressions in the layout or functionality.

Petar.petkovic moved this task from QA to Done on the Language-2018-Jan-Mar board.Mar 2 2018, 12:39 AM